HP Quality Center

Software Version: 10.00

Tutorial

Document Number: T7334-90016
Document Release Date: July 2009
Software Release Date: January 2009
Legal Notices

Warranty

The only warranties for HP products and services are set forth in the express warranty statements accompanying such products and services. Nothing herein should be construed as constituting an additional warranty. HP shall not be liable for technical or editorial errors or omissions contained herein.

The information contained herein is subject to change without notice.

Restricted Rights Legend

Confidential computer software. Valid license from HP required for possession, use or copying. Consistent with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software Documentation, and Technical Data for Commercial Items are licensed to the U.S. Government under vendor’s standard commercial license.

Third-Party Web Sites

HP provides links to external third-party Web sites to help you find supplemental information. Site content and availability may change without notice. HP makes no representations or warranties whatsoever as to site content or availability.

Copyright Notices

© Copyright 1993 - 2009 Hewlett-Packard Development Company, L.P.

Trademark Notices

Adobe® is a trademark of Adobe Systems Incorporated.
Microsoft® and Windows® are U.S registered trademarks of Microsoft Corporation.
Oracle® is a registered trademark of Oracle Corporation and/or its affiliates.
Documentation Updates

The title page of this document contains the following identifying information:

- Software Version number, which indicates the software version.
- Document Release Date, which changes each time the document is updated.
- Software Release Date, which indicates the release date of this version of the software.

To check for recent updates, or to verify that you are using the most recent edition of a document, go to:

   http://h20230.www2.hp.com/selfsolve/manuals

This site requires that you register for an HP Passport and sign-in. To register for an HP Passport ID, go to:

   http://h20229.www2.hp.com/passport-registration.html

Or click the New users - please register link on the HP Passport login page.

You will also receive updated or new editions if you subscribe to the appropriate product support service. Contact your HP sales representative for details.
Support

Visit the HP Software Support web site at:

http://www.hp.com/go/hpsoftwaresupport

This web site provides contact information and details about the products, services, and support that HP Software offers.

HP Software online support provides customer self-solve capabilities. It provides a fast and efficient way to access interactive technical support tools needed to manage your business. As a valued support customer, you can benefit by using the support web site to:

• Search for knowledge documents of interest
• Submit and track support cases and enhancement requests
• Download software patches
• Manage support contracts
• Look up HP support contacts
• Review information about available services
• Enter into discussions with other software customers
• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also require a support contract. To register for an HP Passport ID, go to:

http://h20229.www2.hp.com/passport-registration.html

To find more information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp
# Table of Contents

Welcome to This Tutorial .................................................................7
How This Tutorial Is Organized ..........................................................7
Before You Begin .............................................................................9
Documentation Library .....................................................................10
Additional Online Resources ............................................................13
Documentation Updates ....................................................................14

**Lesson 1: Introducing Quality Center** .................................................15
The Application Life Cycle Management Process ...............................16
Starting Quality Center ....................................................................17
The Quality Center Window ..............................................................20
The Mercury Tours Sample Web Site ..................................................24

**Lesson 2: Specifying Releases and Cycles** ........................................29
Defining Releases and Cycles ..............................................................30
Viewing Releases and Cycles .............................................................31

**Lesson 3: Specifying Requirements** ................................................35
Defining Requirements .......................................................................36
Viewing Requirements .......................................................................41
Converting Requirements ....................................................................44

**Lesson 4: Planning Tests** .................................................................51
Developing a Test Plan Tree ...............................................................52
Designing Test Steps .........................................................................54
Copying Test Steps ...........................................................................57
Calling Tests with Parameters ...........................................................59
Creating and Viewing Requirements Coverage ................................63
Generating Automated Test Scripts ....................................................72
<table>
<thead>
<tr>
<th>Lesson 5: Running Tests .................................................................</th>
<th>75</th>
</tr>
</thead>
<tbody>
<tr>
<td>Defining Test Sets ...................................................................</td>
<td>76</td>
</tr>
<tr>
<td>Adding Tests to a Test Set ....................................................</td>
<td>83</td>
</tr>
<tr>
<td>Scheduling Test Runs ..............................................................</td>
<td>85</td>
</tr>
<tr>
<td>Running Tests Manually ...........................................................</td>
<td>92</td>
</tr>
<tr>
<td>Viewing and Analyzing Test Results .........................................</td>
<td>99</td>
</tr>
<tr>
<td>Running Tests Automatically ....................................................</td>
<td>104</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Lesson 6: Adding and Tracking Defects .....................................</th>
<th>107</th>
</tr>
</thead>
<tbody>
<tr>
<td>How to Track Defects .............................................................</td>
<td>108</td>
</tr>
<tr>
<td>Adding New Defects ...............................................................</td>
<td>109</td>
</tr>
<tr>
<td>Matching Defects .....................................................................</td>
<td>111</td>
</tr>
<tr>
<td>Updating Defects .....................................................................</td>
<td>112</td>
</tr>
<tr>
<td>Linking Defects to Tests ........................................................</td>
<td>116</td>
</tr>
<tr>
<td>Creating Favorite Views ..........................................................</td>
<td>118</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Lesson 7: Alerting on Changes ................................................</th>
<th>123</th>
</tr>
</thead>
<tbody>
<tr>
<td>Triggering an Alert ..................................................................</td>
<td>124</td>
</tr>
<tr>
<td>Creating Follow Up Alerts ......................................................</td>
<td>126</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Lesson 8: Generating Reports and Graphs ...................................</th>
<th>129</th>
</tr>
</thead>
<tbody>
<tr>
<td>Generating Reports ..................................................................</td>
<td>130</td>
</tr>
<tr>
<td>Generating Graphs ...................................................................</td>
<td>138</td>
</tr>
<tr>
<td>Generating Dashboard Pages ....................................................</td>
<td>145</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Lesson 9: Creating Libraries and Baselines ...............................</th>
<th>151</th>
</tr>
</thead>
<tbody>
<tr>
<td>Creating Libraries ..................................................................</td>
<td>152</td>
</tr>
<tr>
<td>Creating Baselines ..................................................................</td>
<td>154</td>
</tr>
<tr>
<td>Comparing Baselines ................................................................</td>
<td>157</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Lesson 10: Customizing Projects ...............................................</th>
<th>163</th>
</tr>
</thead>
<tbody>
<tr>
<td>Starting Project Customization ..............................................</td>
<td>164</td>
</tr>
<tr>
<td>Adding a New Project User ......................................................</td>
<td>167</td>
</tr>
<tr>
<td>Assigning a User to a User Group ..........................................</td>
<td>169</td>
</tr>
<tr>
<td>Defining a User-Defined Field .................................................</td>
<td>171</td>
</tr>
<tr>
<td>Creating a Project List .........................................................</td>
<td>174</td>
</tr>
</tbody>
</table>

| Lesson 11: Conclusion .............................................................. | 179 |
Welcome to This Tutorial

Welcome to this tutorial, a self-paced guide that teaches you how to use HP Quality Center, the HP Web-based solution for application life cycle management.

This tutorial instructs you how to use Quality Center to organize and manage all phases of the application life cycle, including defining releases, specifying requirements, planning tests, executing tests, and tracking defects. It also instructs you how to create baselines for tracking changes in your project over time, and how to customize your project.

To successfully complete the tutorial, you should perform the tutorial in the order in which the information is presented.

How This Tutorial Is Organized

This tutorial contains the following lessons:

Lesson 1   Introducing Quality Center
Introduces you to the application life cycle management process, and familiarizes you with the Quality Center user interface and the sample Mercury Tours Web site.

Lesson 2   Specifying Releases and Cycles
Shows you how to define releases and cycles and monitor their progress and quality.
Welcome to This Tutorial

Lesson 3  Specifying Requirements
Shows you how to define requirements, view the requirements tree, and convert requirements to tests.

Lesson 4  Planning Tests
Shows you how to create a test plan tree, define test steps, link tests to requirements, and automate manual tests.

Lesson 5  Running Tests
Shows you how to define test sets, schedule test runs, and run manual and automated tests.

Lesson 6  Adding and Tracking Defects
Shows you how to add new defects, update defects, and manage defects.

Lesson 7  Alerting on Changes
Shows you how to keep track of changes made to your requirements, tests, and defects as you perform your project testing.

Lesson 8  Generating Reports and Graphs
Shows you how to monitor the application life cycle management process by creating reports and graphs.

Lesson 9  Creating Libraries and Baselines
Shows you how to create libraries and baselines, and how to compare baselines to track changes in your project.

Lesson 10  Customizing Projects
Shows you how to set up project users, and how to create project fields and lists.

Lesson 11  Conclusion
Summarizes the Quality Center application life cycle management process and suggests the steps to consider for each phase.
Before You Begin

To work with this tutorial, consider the following specifications:

Important: The lessons in this tutorial are based on the QualityCenter_Demo project. Verify with your administrator that you are working with the correct version of the QualityCenter_Demo project. This version is available with Quality Center 10.00 Patch 1 (or above) and is obtained by importing the QualityCenter_Demo.qcp file using Site Administration. For more information, refer to the HP Quality Center Installation Guide.

<table>
<thead>
<tr>
<th>Specifications</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Quality Center Editions</td>
<td>Quality Center is available in three different editions — Starter, Enterprise and Premier. This tutorial assumes that you are working in Quality Center Enterprise Edition or Quality Center Premier Edition. Some of the lessons and exercises in this tutorial are not applicable if you are working in Quality Center Starter Edition. To determine which Quality Center edition you are using, contact your Quality Center site administrator.</td>
</tr>
<tr>
<td>QualityCenter_Demo</td>
<td>A demo project that introduces you to Quality Center and includes sample releases, requirements, tests, test sets, test runs, and defects. To ensure that you get the same results as the ones specified in this tutorial, make sure that you work on a new copy of the QualityCenter_Demo project. For more information, contact your Quality Center site administrator.</td>
</tr>
</tbody>
</table>
The Documentation Library is an online help system that describes how to use Quality Center. You can access the Documentation Library in the following ways:

➤ Click Documentation Library in the Quality Center Help menu to open the Documentation Library home page. The home page provides quick links to the main help topics.

➤ Click Help on this page in the Quality Center Help menu to open the Documentation Library to the topic that describes the current page.
Documentation Library Guides

The Documentation Library consists of the following guides and references, available online, in PDF format, or both. PDFs can be read and printed using Adobe Reader, which can be downloaded from the Adobe Web site (http://www.adobe.com).

Getting Started explains how to use the Documentation Library and how it is organized. (Available online.)

What’s New? describes the newest features in the latest version of Quality Center. (Available online and in PDF format.)

You can also access What’s New? from the Quality Center Help menu. In addition, you can select Help > Product Feature Movies to view short movies that demonstrate the main product features.

Readme provides last-minute news and information about Quality Center.

Quality Center Guides

HP Quality Center User Guide explains how to use Quality Center to organize and execute all phases of the application life cycle management process. It describes how to specify releases, define requirements, plan tests, run tests, and track defects. (Available online and in PDF format.)

HP Quality Center Administrator Guide explains how to create and maintain projects using Site Administration, and how to customize projects using Project Customization. (Available online and in PDF format.)

HP Quality Center Tutorial is a self-paced guide teaching you how to use Quality Center to manage the application life cycle management process. (Available in PDF format.)

HP Quality Center Installation Guide explains how to install Quality Center on a server machine in a cluster environment or as a standalone application. (Available in PDF format.)

HP Quality Center Upgrade Preparation Guide explains how to detect and repair problems before beginning a project upgrade. (Available in PDF format.)

HP Quality Center Database Best Practices Guide provides best practices for deploying Quality Center on database servers. (Available in PDF format.)
Welcome to This Tutorial

**Business Process Testing Guides**


**HP Business Process Testing Tutorial** provides a self-paced guide that teaches you the basics of Business Process Testing in Quality Center. (Available in PDF format.)

**API References**

**HP Quality Center Database Reference** provides a complete online reference for the project database tables and fields. (Available online.)

**HP Quality Center Open Test Architecture API Reference** provides a complete online reference for the Quality Center COM-based API. You can use the Quality Center open test architecture to integrate your own configuration management, defect tracking, and home-grown testing tools with a Quality Center project. (Available online.)

**HP Quality Center Site Administration API Reference** provides a complete online reference for the Site Administration COM-based API. You can use the Site Administration API to enable your application to organize, manage, and maintain Quality Center users, projects, domains, connections, and site configuration parameters. (Available online.)

**HP Quality Center Entity Dependencies API Reference** provides an online reference for managing relations between Quality Center entities. The reference covers a subset of the Quality Center COM-based API and a subset of the data tables used when managing relations. You can use this reference to integrate testing tools with Quality Center. (Available online.)

**HP Quality Center Custom Test Type Guide** provides a complete online guide for creating your own testing tool and integrating it into the Quality Center environment. (Available online.)
Additional Online Resources

The following additional online resources are available from the Quality Center Help menu:


**HP Software Support** accesses the HP Software Support Web site. This site enables you to browse the Self-solve knowledge base. You can also post to and search user discussion forums, submit support requests, download patches and updated documentation, and more. Choose Help > HP Software Support. The URL for this Web site is [www.hp.com/go/hpsoftwaresupport](http://www.hp.com/go/hpsoftwaresupport).

Most of the support areas require that you register as an HP Passport user and sign in. Many also require a support contract.

To find more information about access levels, go to: [http://h20230.www2.hp.com/new_access_levels.jsp](http://h20230.www2.hp.com/new_access_levels.jsp)

To register for an HP Passport user ID, go to: [http://h20229.www2.hp.com/passport-registration.html](http://h20229.www2.hp.com/passport-registration.html)

**HP Software Web site** accesses the HP Software Web site. This site provides you with the most up-to-date information on HP Software products. This includes new software releases, seminars and trade shows, customer support, and more. Choose Help > HP Software Web site. The URL for this Web site is [www.hp.com/go/software](http://www.hp.com/go/software).

**Add-ins Page** opens the HP Quality Center Add-ins Page, which offers integration and synchronization solutions with HP and third-party tools. For more information, refer to the *HP Quality Center Installation Guide*.
Welcome to This Tutorial

Documentation Updates

HP Software is continually updating its product documentation with new information.

To check for recent updates, or to verify that you are using the most recent edition of a document, go to the HP Software Product Manuals Web site (http://h20230.www2.hp.com/selfsolve/manuals).
Introducing Quality Center

Quality Center helps you organize and manage all phases of the application life cycle management process, including defining releases, specifying requirements, planning tests, executing tests, and tracking defects.

In this lesson, you will learn about:

➤ The Application Life Cycle Management Process on page 16
➤ Starting Quality Center on page 17
➤ The Quality Center Window on page 20
➤ The Mercury Tours Sample Web Site on page 24
The Application Life Cycle Management Process

The application life cycle management process with Quality Center includes the following phases:

➤ **Specify Releases.** Develop a release-cycle management plan.

➤ **Specify Requirements.** Analyze your application and determine your requirements.

➤ **Plan Tests.** Plan and confirm which tests need to be performed and how these tests must be run.

➤ **Run Tests.** Organize test sets, schedule their execution, perform test runs, and analyze the results of these runs.

➤ **Track Defects.** Add defects that were detected in the application and track how repairs are progressing.

Throughout the process, you can generate reports and graphs to assist you in “go/no-go” decisions about your application readiness.
Starting Quality Center

You start Quality Center from your Web browser using the HP Quality Center URL.

To start Quality Center:

1 Verify tutorial prerequisites.

Before you begin the lessons in this tutorial, verify that you have the appropriate prerequisites. For more information, see “Before You Begin” on page 9.

2 Open the Quality Center Options window.

Open your Web browser and type your Quality Center URL: http://<Quality Center server name>[:<port number>]/qcbin. Contact your system administrator if you do not have the correct path.

The Quality Center Options window opens.
3 Open Quality Center.

Click the Quality Center link.

The first time you run Quality Center, files are downloaded to your machine, and if it is not already installed, the Microsoft .NET Framework 2.0 Setup program runs. Subsequently, Quality Center carries out a version check. If there is a newer version on the server, updated files are downloaded to your machine.

The Quality Center Login window opens.

4 Type a user name and authenticate.

In the Login Name box, type one of the following names: alice qc, cecil qc, or michael qc.

Skip the Password box. A password was not assigned to any of the above user names.

Click the Authenticate button. Quality Center verifies your user name and password and determines which domains and projects you can access.
5 Log in to the project.

In the Domain list, select DEFAULT.

In the Project list, select QualityCenter_Demo. If more than one QualityCenter_Demo project is listed, contact your Quality Center site administrator to determine which project to use.

Click the Login button.

The first time you run Quality Center, the Welcome page opens. From the Welcome page, you can directly access the Quality Center documentation and feature movies.

When you log in to a project, the Quality Center main window opens and displays the module in which you were last working. In the upper-right corner of the window, the domain name, project name, and your user name are displayed.
Lesson 1 • Introducing Quality Center

The Quality Center Window

In this exercise, you will explore the Quality Center modules and their common elements. You will also learn how to navigate the online help.

To explore the Quality Center window:

1 Explore the Quality Center modules.

Click the following buttons on the sidebar:

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
</table>
| ![Management](image) | The **Management** module includes the following sub-modules:  
➤ **Releases**. Enables you to define releases and cycles for the application management process.  
➤ **Libraries**. Enables you to define libraries to track changes in your project, reuse entities in a project, or share entities across multiple projects.  
**Quality Center Starter Edition**: The Management module is not available for Quality Center Starter Edition. |
| ![Requirements](image) | The **Requirements** module enables you to manage requirements in a hierarchical tree-structure. Requirements can be linked to other requirements, tests, or defects. |
| ![Business Components](image) | Depending on your Quality Center license, you may also have access to the **Business Components** module. The Business Components module enables subject matter experts to drive the quality optimization process. For more information, refer to the *HP Business Process Testing User Guide*. |
| ![Test Plan](image) | The **Test Plan** module enables you to develop and manage tests in a hierarchical tree-structure. Tests can be linked to requirements and defects. |
| ![Test Resources](image) | The **Test Resources** module enables you to manage test resources in a hierarchical tree-structure. Test resources can be associated with tests. |
| ![Test Lab](image) | The **Test Lab** module enables you to run tests on your application and analyze the results. |
Lesson 1 • Introducing Quality Center

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Defects Button" /></td>
<td>The <strong>Defects</strong> module enables you to add defects, determine repair priorities, repair open defects, and analyze the data.</td>
</tr>
<tr>
<td><img src="image" alt="Dashboard Button" /></td>
<td>The <strong>Dashboard</strong> module enables you to create graphs, reports, and Excel reports. You can also create dashboard pages, which enable you to view multiple graphs side-by-side.</td>
</tr>
</tbody>
</table>

2 Explore the common Quality Center elements.

All the Quality Center modules have common elements. For example, click the **Requirements** button on the sidebar.
Lesson 1 • Introducing Quality Center

Each of the Quality Center modules contains the following key elements:

➤ **Quality Center common toolbar.** This toolbar is accessible from all modules and contains the following buttons:

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Back</td>
<td>Navigates back to your previous location in Quality Center.</td>
</tr>
<tr>
<td>Forward</td>
<td>Navigates forward to your next location in Quality Center.</td>
</tr>
<tr>
<td>Tools</td>
<td>Includes options that enable you to select a different project, customize your project, add new defects, check spelling and grammar, delete history data from your project, and open the Document Generator.</td>
</tr>
<tr>
<td>Help</td>
<td>Enables you to open the Quality Center Documentation Library and other additional online resources. It also enables you to display version information for each Quality Center client component. For more information, see “Documentation Library” on page 10 and “Additional Online Resources” on page 13.</td>
</tr>
<tr>
<td>Logout</td>
<td>Logs you out of your current project and returns you to the Quality Center Login window.</td>
</tr>
</tbody>
</table>

➤ **Module menu bar.** Displays the names of menus from which you select commands in the current Quality Center module.

➤ **Module toolbar.** This is located below the menu bar. It contains buttons for frequently used commands in the current Quality Center module.

3 **View Quality Center help topics.**

To view the help topic of the Requirements module window, click the **Requirements** button on the sidebar. The Requirement module is displayed. Choose Help > Help on this page. The help topic opens in a separate window.

To display the navigation pane, which includes the Contents, Index, Search, and Favorites tabs, click the **Show Navigation** button. The navigation pane is displayed on the left side of the page.
Lesson 1 • Introducing Quality Center

To view the Quality Center Documentation Library home page, in the Contents tab, click **Home**. The Documentation Library home page opens.

The Documentation Library consists of guides and references, available online, in PDF format, or both.

Click the **Close** button.
Lesson 1 • Introducing Quality Center

The Mercury Tours Sample Web Site

Mercury Tours is the sample Web application used in this tutorial. It simulates a Web-based application for reserving flights, hotel rooms, car rentals, cruises, and vacation deals. Before continuing with the tutorial, familiarize yourself with this application.

To explore Mercury Tours:

1 Open the Mercury Tours application.

Open a separate instance of your Web browser, and type this URL:
http://<Quality Center server name>:<port number>/mtours

The Mercury Tours home page opens.
2 Register with Mercury Tours.

Click Register. The Register page opens.

Under User Information, enter any user name and password, and confirm your password. (Other information is not required.)

Click Submit. Mercury Tours confirms your registration.
Lesson 1 • Introducing Quality Center

3 Log on to Mercury Tours.

Click Sign-on. The Sign-on page opens.

Type your registered user name and password. Click Submit.
The Flight Finder page opens.

4 Reserve a flight.

Follow the on-screen instructions to reserve a flight.

5 End your Mercury Tours session.

Click Sign-off to log out.
Specifying Releases and Cycles

You begin the application life cycle management process by specifying releases and cycles. A release represents a group of changes in one or more applications that will be available for distribution at the same time. Each release can contain a number of cycles. A cycle represents a development and QA cycle based on the project timeline. The releases and cycles have defined start and end dates.

You can organize and track your upcoming releases by defining a hierarchical releases tree containing releases and cycle. In this lesson, you will add a release to an existing releases tree, and then add cycles to the release.

Quality Center Starter Edition: This lesson is not available for Quality Center Starter Edition.

In this lesson, you will learn about:
- Defining Releases and Cycles on page 30
- Viewing Releases and Cycles on page 31
Defining Releases and Cycles

In this exercise, you will define a release and then add cycles to the release. Releases and cycles each have start dates and end dates. The date range for a cycle must be contained within the date range of the release.

To define a release and its cycles:

1 Open the QualityCenter_Demo project.
   If the QualityCenter_Demo project is not already open, log in to the project. For more information, see “Starting Quality Center” on page 17.

2 Display the Releases module.
   Click the Management button on the sidebar and then click the Releases tab.

3 Create a new release folder.
   In the releases tree, select the root Releases folder. Click the New Release Folder button. The New Release Folder dialog box opens.
   In the Release Folder Name box, type Service Packs.
   Click OK. The Service Packs release folder is added to the releases tree.
   In the Description box in the right pane, type the following description for the release folder: This folder contains service pack releases.

4 Add a release.
   In the releases tree, make sure that the new Service Packs release folder is selected.
   Click the New Release button. The New Release dialog box opens.
   In the Release Name box, type Service Pack 1.
   Click OK. The Service Pack 1 release is added to the Service Packs release folder.

   In the right pane, in the Start Date box, click the down arrow and select yesterday’s date. In the End Date box, click the down arrow and select the date two months from today’s date. In the Description box, type the following description for the release: This release is the first service pack release.
Lesson 2 • Specifying Releases and Cycles

5 Add a cycle to the release.

In the releases tree, select the Service Pack 1 release.

Click the New Cycle button. The New Cycle dialog box opens.

In the Cycle Name box, type Cycle 1 - New Features.

Click OK. The Cycle 1 - New Features cycle is added to the Service Pack 1 release.

In the right pane, in the Start Date box, click the down arrow and select yesterday’s date. In the End Date box, click the down arrow and select the date a month from today’s date. In the Description box, type the following description for the cycle: This cycle tests new features added for this service pack.

6 Add a second cycle to the release.

In the releases tree, right-click the Service Pack 1 release and choose New Cycle. The New Cycle dialog box opens.

In the Cycle Name box, type Cycle 2 - Full.

Click OK. The Cycle 2 - Full cycle is added to the Service Pack 1 release.

In the right pane, in the Start Date box, click the down arrow and select the date one month and a day from today’s date. In the End Date box, click the down arrow and select the date two months from today’s date. In the Description box, type the following description for the cycle: This cycle fully tests all application features.

Viewing Releases and Cycles

You can view graphs and statistics to display the progress of your releases and cycles. This exercise introduces these graphs and statistics. In later lessons, you will see how the graphs and statistics change to reflect the changing status of your project.

To view releases and cycles:

1 Make sure the Releases module is displayed.

If the Releases module is not displayed, click the Management button on the sidebar and then click the Releases tab.
2 Display the Progress graph for the Service Pack 1.

In the releases tree, select the Service Pack 1 release, located in the Service Packs release folder. In the right pane, click the Progress tab.

The Progress tab displays the progress of the release based on requirement coverage, elapsed and remaining time, and actual and remaining test instances to run. As you have not yet created requirements or tests, the information in the Coverage Progress graph indicates 0% progress.
3 Display the Progress graph for a cycle.

In the releases tree, select the **Cycle 1 - New Features** cycle, located in the **Service Pack 1** release.

In the right pane, click the **Progress** tab. You can see that the information available is similar to that available for the release, but at the cycle level. As in the case of the release, you have not yet created requirements and tests, therefore the information in the Coverage Progress graph indicates 0% progress.
Lesson 2 • Specifying Releases and Cycles
3

Specifying Requirements

Requirements describe in detail what needs to be solved or achieved to meet the objectives of your application under development.

You define the requirements in Quality Center by creating a requirements tree in the Requirements module. This is a graphical representation of your requirements specification, displaying your requirements hierarchically. You can group and sort requirements in the tree, monitor the progress in meeting requirements, and generate detailed reports and graphs. In this lesson, you will create requirements in an existing requirements tree. You will then assign the requirements to a cycle in the releases tree.

In this lesson, you will learn about:

➤ Defining Requirements on page 36
➤ Viewing Requirements on page 41
➤ Converting Requirements on page 44
Lesson 3 • Specifying Requirements

Defining Requirements

In this exercise, you will define requirements for testing the functionality of reserving cruises in Mercury Tours.

Quality Center Starter Edition: If you are using Quality Center Starter Edition, multiple requirement types are not supported. In addition, fields and commands related to cycles and releases are not available.

To define a requirement:

1 Open the QualityCenter_Demo project.
   If the QualityCenter_Demo project is not already open, log in to the project. For more information, see “Starting Quality Center” on page 17.

2 Display the Requirements module.
   Click the Requirements button on the sidebar.

3 Select the Mercury Tours Application requirement.
   Choose View > Requirements Tree to display requirements in a tree.

4 Create a new requirement and assign it to a requirement type.
   Quality Center Starter Edition: If you are using Quality Center Starter Edition, proceed to Step 5 on page 38.

   Click the New Requirement button. The Create New Requirement dialog box opens.
Lesson 3 • Specifying Requirements

In the **Requirement Type** box, select **Functional**. Each requirement belongs to a requirement type. The requirement type to which a requirement belongs determines which fields are available for the requirement. Your project administrator can modify existing types and add new types.

In the **Requirement Name** box, type Cruise Reservation.

Click **OK**. The New Requirement dialog box opens.
Lesson 3 • Specifying Requirements

5 Quality Center Starter Edition: Create a new requirement.
This step only applies if you are using Quality Center Starter Edition.
Click the New Requirement button. The New Requirement dialog box opens.

In the Requirement Name box, type Cruise Reservation.

6 Add details to the requirement.
Type or select the following:
Priority: 4-Very High
Product: Mercury Tours Web Site
Click Submit. The Cruise Reservation requirement is added to the requirements tree under the Mercury Tours Application requirement.
Click Close to close the New Requirement dialog box.
7 Add a child requirement and assign it to a requirement type.

Quality Center Starter Edition: If you are using Quality Center Starter Edition, proceed to Step 8.

In the requirements tree, make sure that the new Cruise Reservation requirement is selected.

Click the New Requirement button to add a requirement below Cruise Reservation.

In the Create New Requirement dialog box, select Functional in the Requirement Type box and type Cruise Search in the Requirement Name box. Click OK. The New Requirement dialog box opens.

Type or select the following:

**Priority:** 4-Very High

**Product:** Mercury Tours Web Site

Click Submit. The Cruise Search requirement is added as a child of the Cruise Reservation requirement. Click Close to close the New Requirement dialog box.

8 Quality Center Starter Edition: Add a child requirement.

This step only applies if you are using Quality Center Starter Edition.

In the requirements tree, make sure that the new Cruise Reservation requirement is selected.

Click the New Requirement button to add a requirement below Cruise Reservation.

In the New Requirement dialog box, type Cruise Search in the Requirement Name box.

Type or select the following:

**Priority:** 4-Very High

**Product:** Mercury Tours Web Site

Click Submit. The Cruise Search requirement is added as a child of the Cruise Reservation requirement. Click Close to close the New Requirement dialog box.
Lesson 3 • Specifying Requirements

9 Add the Cruise Booking child requirement.

Quality Center Starter Edition: If you are using Quality Center Starter Edition, proceed to Step 10.

In the requirements tree, make sure that the Cruise Reservation requirement is selected.

Click the New Requirement button to add a requirement below Cruise Reservation.

In the Create New Requirement dialog box, select Functional in the Requirement Type box and type Cruise Booking in the Requirement Name box. Click OK. The New Requirement dialog box opens.

Type or select the following:

Priority: 4-Very High
Product: Mercury Tours Web Site

Click Submit. The Cruise Booking requirement is added as a child of the Cruise Reservation requirement. Click Close to close the New Requirement dialog box.

10 Quality Center Starter Edition: Add the Cruise Booking child requirement.

This step only applies if you are using Quality Center Starter Edition.

In the requirements tree, make sure that the Cruise Reservation requirement is selected.

Click the New Requirement button to add a requirement below Cruise Reservation.

In the New Requirement dialog box, type Cruise Booking in the Requirement Name box.

Type or select the following:

Priority: 4-Very High
Product: Mercury Tours Web Site

Click Submit. The Cruise Booking requirement is added as a child of the Cruise Reservation requirement. Click Close to close the New Requirement dialog box.
Assign the requirements to a cycle.

**Quality Center Starter Edition:** If you are using Quality Center Starter Edition, ignore this step.

In the requirements tree, select **Cruise Reservation**.

Choose **Requirements > Assign to Cycle**. The releases tree opens. In the **Service Packs** releases folder, in the **Service Pack 1** release, select the check box for the **Cycle 1 - New Features** cycle.

Click **OK** to close the releases tree.

Click **Yes** to assign the cycle to the requirement and its sub requirements.

**Viewing Requirements**

You can change the way requirements are displayed. In this exercise, you will learn how to zoom in and out of the requirements tree, and how to display and filter requirements in the requirements grid.

**To view requirements:**

1. **Make sure the Requirements module is displayed.**

   If the Requirements module is not displayed, click the **Requirements** button on the sidebar.

   Choose **View > Requirements Tree** to display requirements in the Requirements Tree view.

2. **Zoom in and out of the requirements tree.**

   Select **Cruise Reservation** in the requirements tree.
Lesson 3 • Specifying Requirements

To zoom in, click the Zoom In button in the toolbar. The requirements tree displays only the child requirements of Cruise Reservation.

<table>
<thead>
<tr>
<th>Requirements</th>
<th>Edit</th>
<th>View</th>
<th>Favorites</th>
<th>Analysis</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cruise Search</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cruise Booking</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

To reverse the zoom-in action and display the entire requirements tree, click the Zoom In arrow and choose Zoom Out To Root.

3 View requirements in the requirements grid.

Choose View > Requirements Grid to display requirements in a flat non-hierarchical view. Each line in the grid displays a separate requirement.

4 Define a filter to view requirements created on a specific date.

Click the Set Filter/Sort button. The Filter dialog box opens.
Lesson 3 • Specifying Requirements

For the **Creation Date** field, click the **Filter Condition** box. Click the browse button. The Select Filter Condition dialog box opens, displaying today's date in the calendar.

Select the date on which you added requirements.

Click **OK** to close the Select Filter Condition dialog box.

Click **OK** to apply your chosen filter.

The Requirements Grid displays the requirements you added.
Converting Requirements

After you create the requirements tree, you can use the requirements as a basis for defining your test plan tree in the Test Plan module. For more information, see the lesson “Planning Tests” on page 51.

You can use the Convert to Tests wizard to assist you when designing your test plan tree. The wizard enables you to convert selected requirements or all requirements in the requirements tree to subjects or tests in the test plan tree.

In this exercise, you will convert the Cruise Reservation requirement to a subject in the test plan tree, and the child requirements of Cruise Reservation to tests in the Cruise Reservation subject folder.

To convert a requirement:

1. Make sure the Requirements module is displayed.
   
   If the Requirements module is not displayed, click the Requirements button on the sidebar.
   
   Choose View > Requirements Tree to display requirements in the Requirements Tree view.

2. Select a requirement.
   
   In the requirements tree, select Cruise Reservation.
3 Open the Convert to Tests wizard. Choose **Requirements > Convert to Tests**. The Step 1 dialog box opens.

![Step 1 of 3. Choose an automatic conversion method](image)

4 Choose an automatic conversion method.

Select the second option, **Convert lowest child requirements to tests**, to convert the selected requirement to a subject folder, and its child requirements to tests.
5 Start the conversion process.

Click **Next** to begin converting the requirements. When the conversion process is complete, the results are displayed in the Step 2 dialog box.
Click **Next**. The Step 3 dialog box opens.

6 **Choose the destination subject path.**

In the **Destination Subject Path** box, click the browse button. The Select Destination Subject dialog box opens.

If any filters are applied, click the **Set Filter/Sort** arrow and choose **Clear Filter/Sort**. Click **Yes** to confirm.
In the test plan tree, select the **Cruises** subject.

Click **OK** to close the Select Destination Subject dialog box. The **Destination Subject Path** box now indicates this path:

7 **Finalize the conversion process.**

Click **Finish**. Click **OK**.

8 **View the tests in the test plan tree.**

Click the **Test Plan** button on the sidebar to display the Test Plan module. In the test plan tree, expand **Cruises**. The test plan tree displays **Cruise Reservation** under **Cruises**.
Expand **Cruise Reservation**. The test plan tree displays the **Cruise Booking** and **Cruise Search** tests.
Lesson 3 • Specifying Requirements
After you define your requirements, you need to determine your testing goal and outline the strategy for achieving your goal.

After you determine your testing goal, you build a **test plan tree**, which hierarchically divides your application into testing units, or subjects. For each subject in the test plan tree, you define tests that contain steps.

For each test step, you specify the actions to be performed on your application and the expected result. You can increase the flexibility of a test step by adding parameters.

To keep track of the relationship between your tests and your requirements, you can link them. This can help you ensure compliance with your requirements throughout the application life cycle management process.

After you design your tests, you can decide which tests to automate. When you automate a test, you can generate a test script and then complete it using other HP testing tools (for example, QuickTest Professional or WinRunner).

**In this lesson, you will learn about:**

- Developing a Test Plan Tree on page 52
- Designing Test Steps on page 54
- Copying Test Steps on page 57
- Calling Tests with Parameters on page 59
- Creating and Viewing Requirements Coverage on page 63
- Generating Automated Test Scripts on page 72
Developing a Test Plan Tree

The typical application is too large to test as a whole. The Test Plan module enables you to divide your application according to functionality. You divide your application into units, or subjects, by creating a test plan tree. The test plan tree is a graphical representation of your test plan, displaying your tests according to the hierarchical relationship of their functions. After you define subjects in the tree, you decide which tests to create for each subject, and add them to the tree.

In Lesson 3, you converted the Cruise Reservation requirement and its child requirements to subjects and tests in the test plan tree (see “Converting Requirements” on page 44). In this exercise, you will add a subject and a test to the test plan tree in the Test Plan module.

To develop a test plan tree:

1 Open the QualityCenter_Demo project.
   If the QualityCenter_Demo project is not already open, log in to the project. For more information, see “Starting Quality Center” on page 17.

2 Display the Test Plan module.
   Click the Test Plan button on the sidebar.

3 Add a subject folder to the test plan tree.
   Select the Cruises subject folder and click the New Folder button. The New Folder dialog box opens.
   In the Folder Name box, type Cruise Cancellation. Click OK. The new subject folder appears under the Cruises subject folder in the test plan tree.
   In the Description tab in the right pane, type a description of the subject: This folder contains tests that verify the Cancel Reservation functionality.

4 Add a test to the subject folder.
   Select the Cruise Cancellation folder and click the New Test button. The Create New Test dialog box opens.
   In the Test Type box, select QUICKTEST_TEST to create a QuickTest Professional test, or select WR-AUTOMATED to create a WinRunner test.
In the **Test Name** box, type a name for the test: Cancel All Reservations. Click **OK**. The Required Test Fields dialog box opens.

Select the following:

**Level**: Basic

**Reviewed**: Not Reviewed

**Priority**: 4-Very High

Click **OK**. The new test is added to the test plan tree under the **Cruise Cancellation** Subject folder.
Lesson 4 • Planning Tests

5 Add a test description.

In the Details tab, you can see the test name, test designer, creation date, test status, and other information.

In the Description tab, type a description for the test: The test verifies cancellation of cruise reservations in the Itinerary page.

Designing Test Steps

After you add a test to the test plan tree and define basic test information, you define test steps—detailed, step-by-step instructions that specify how to execute the test. A step includes the actions to be performed on your application and the expected results.

You can create test steps for both manual and automated tests. For manual tests, you complete test planning by designing the test steps. Using your plan, you can begin test execution immediately. For automated tests, you create automated test scripts using HP testing tools, custom testing tools, or third-party testing tools.

In this exercise, you will create the Cruise Booking test. This test verifies the process of booking a cruise through the Mercury Tours site.

To design a test step:

1 Make sure the Test Plan module is displayed.

If the Test Plan module is not displayed, click the Test Plan button on the sidebar.

2 Display the Cruise Booking test.

Expand the Cruises and Cruise Reservation subject folders, and select the Cruise Booking test.

3 Open the Design Step Editor.

Click the Design Steps tab.
Click the **New Step** button. The Design Step Editor opens.

In the **Step Name** box, a step name is displayed. The default name is the sequential number of the test step (**Step 1** if you are adding steps to a test for the first time).

4 **Define a step for displaying the Cruise Special page.**

In the Design Step Editor, type the following:

- **Step Name**: Display the Cruise Special page.
- **Description**: Click the Cruises button.
- **Expected Result**: The Cruise Special page opens.

5 **Define a step for reserving the cruise.**

In the Design Step Editor, make sure the previous step is selected.

Click the **New Step** button. The **Step Name** box displays **Step 2**.

Type the following:

- **Step Name**: Display the Cruise Reservation page.
- **Description**: Click the Now Accepting Reservations button.
- **Expected Result**: The Cruise Reservation page opens.
6 Define a step for booking the cruise.
In the Design Step Editor, make sure the previous step is selected.
Click the New Step button. The Step Name box displays Step 3.
Type the following:
Step Name: Book the cruise.
Description: Enter passenger name, credit card information, and address. Click OK.
Expected Result: The Cruise Confirmation page opens.

7 Define a step for printing the cruise confirmation information.
In the Design Step Editor, make sure the previous step is selected.
Click the New Step button. The Step Name box displays Step 4.
Type the following:
Step Name: Print cruise confirmation.
Description: Click the Print button.
Expected Result: A confirmation page is printed.

8 Define a step for logging off the Mercury Tours site.
In the Design Step Editor, make sure the previous step is selected.
Click the New Step button. The Step Name box displays Step 5.
Type the following:
Step Name: Log off.
Description: Click the Sign-Off button.
Expected Result: Returns to the Sign-On page.
9 Close the Design Step Editor.

Click **OK**. The Design Steps tab displays the design steps.

### Copying Test Steps

You can copy steps from another test in the same project or from a different project. In this exercise, you will copy the test steps from the **Cruise Booking** test and paste them into the **Cruise Search** test.

**To copy a test step:**

1. **Display the Design Steps tab for the Cruise Booking test.**

   In the test plan tree, expand the **Cruises** and **Cruise Reservation** subject folders, and select the **Cruise Booking** test.

   Click the **Design Steps** tab.
Lesson 4 • Planning Tests

2 Select the steps that you want to copy.
Position the mouse pointer in the gray sidebar on the left. The mouse pointer changes to an arrow. Press the SHIFT or CTRL key and select each row.

<table>
<thead>
<tr>
<th>Step Name</th>
<th>Description</th>
<th>Expected Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display the Cruise Special page</td>
<td>Click the Cruises button.</td>
<td>The Cruise Special page opens.</td>
</tr>
<tr>
<td>Display the Cruise Reservation page</td>
<td>Click the Now Accepting Reservations button.</td>
<td>The Cruise Reservation page opens.</td>
</tr>
<tr>
<td>Book the cruise.</td>
<td>Enter passenger name, credit card information, and address. Click OK.</td>
<td>The Cruise Confirmation page opens.</td>
</tr>
<tr>
<td>Print cruise confirmation</td>
<td>Click the Print button.</td>
<td>A confirmation page is printed.</td>
</tr>
<tr>
<td>Log off.</td>
<td>Click the Sign-Off button.</td>
<td>Returns to the Sign-On page.</td>
</tr>
</tbody>
</table>

3 Copy the selected steps.
Click the Copy Steps button.

4 Paste the steps into the Cruise Search test.
In the test plan tree, select the Cruise Search test.
In the Design Steps tab, click the Paste Steps button. The test steps are copied to the Design Steps tab.
Calling Tests with Parameters

To increase the flexibility of manual tests, you can add parameters to design steps. This enables you to run the same test repeatedly with different data each time. A test parameter is a variable that can be assigned a value outside the test from which it is defined.

Manual tests with parameters can be called from other tests. This is useful if you have common steps you often want to perform as part of other tests. For example, you can create a template test Login_Template that logs a user in when you start the application. You need to call this test at the beginning of each test. In some cases, you will want to log in as a regular user while in others, you will need to log in as the project administrator.

For this purpose, you can create two parameters, <<<user name>>> and <<<password>>>, and change the values according to the type of test that is calling Login_Template. If the most common login is a regular user, you can set the default values for the parameters to a regular user name and password.

In “Designing Test Steps” on page 54, you created a test for booking a cruise. In this exercise, you will enhance your test by calling the Connect And Sign-On test. This template test includes parameters for the Mercury Tours URL address and for the user name and password used to log in to the site.

To call a test with parameters:

1 Display the Design Steps tab for the Cruise Booking test.

In the test plan tree, expand the Cruises and Cruise Reservation subject folders, and select the Cruise Booking test.

Click the Design Steps tab.
Lesson 4 • Planning Tests

2 Select the test with parameters that you want to call.

Click the **Call to Test** button. The Select a Test dialog box opens.

In the **Find** box, type **Connect**, and click the **Find** button. The **Connect And Sign-On** test is highlighted.
Click **OK**. The Parameters of Test dialog box opens and displays the parameters contained in the called test.

![Parameters of Test dialog box](image)

3 **Assign actual values to the parameters.**

In the **Actual Value** column, type the following:

**user name:** Your user name. Use the same name as the one used in Mercury Tours. For more information, see “The Mercury Tours Sample Web Site” on page 24.

**mercury tours url:** `http://<Quality Center server name>[:<port number>]//mtours`

**password:** Leave blank. You will assign a value to this parameter when you run your test (see “Running Tests Manually” on page 92).

Click **OK**. The **Call <Connect And Sign-On>** step is added to your design steps.
4 **Reorder the steps.**

Position the mouse pointer on the gray sidebar to the left of the **Call Connect And Sign-On** step. The mouse pointer changes to an arrow. Click and drag the step to the top row.

<table>
<thead>
<tr>
<th>Step Name</th>
<th>Description</th>
<th>Expected Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Call Connect</td>
<td>Call Connect And Sign-On with the Cruise Special page.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Display the Cruise Special page.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Click the Cruises button.</td>
<td>The Cruise Special page opens.</td>
</tr>
<tr>
<td>Display Cruise Res.</td>
<td>Click the Now Accepting Reservations button.</td>
<td>The Cruise Reservation page opens.</td>
</tr>
<tr>
<td>Book the cruise.</td>
<td>Enter passenger name, credit card information, and address. Click OK.</td>
<td>The Cruise Confirmation page opens.</td>
</tr>
<tr>
<td>Print cruise confirmation</td>
<td>Click the Print button.</td>
<td>A confirmation page is printed.</td>
</tr>
<tr>
<td>Log off.</td>
<td>Click the Sign-Off button.</td>
<td>Returns to the Sign-On page.</td>
</tr>
</tbody>
</table>
Creating and Viewing Requirements Coverage

It is essential that the tests in your test plan comply with your requirements. To help ensure compliance throughout the application life cycle management process, you can add links between your tests in the Test Plan module and your requirements in the Requirements module.

In the Test Plan module, you create requirements coverage by selecting requirements to link to a test. Alternatively, in the Requirements module, you create tests coverage by selecting tests to link to a requirement. A test can cover more than one requirement, and a requirement can be covered by more than one test.

To further ensure compliance with your testing requirements, after you log defects, you can link your requirements and tests to defects (see “Linking Defects to Tests” on page 116). This ensures that if a requirement changes, you can identify which tests and defects are affected, and who is responsible for them.

In these exercises, you will learn about the following:

➤ Linking Requirements to a Test
➤ Linking Tests to a Requirement
➤ Analyzing Test Coverage

Linking Requirements to a Test

In this exercise you will view existing requirements coverage for the Cruise Booking test and create new requirements coverage by linking the Cruise Search requirement to the Cruise Booking test.

You will also add requirements coverage for the following tests: Cancel All Reservations, Airline Preference, and Number of Passengers.

To link a requirement to a test:

1 Make sure that the Test Plan module is displayed.

If the Test Plan module is not displayed, click the Test Plan button on the sidebar.
2 Display the Cruise Booking test.
   Expand the Cruises and Cruise Reservation subject folders, and select the Cruise Booking test.

3 Display the Req Coverage tab.
   In the right pane, click the Req Coverage tab. The existing requirements coverage is displayed in the coverage grid. Note that the Cruise Booking requirement is already linked to the Cruise Booking test because you converted the requirement to a test (see “Converting Requirements” on page 44).

4 Display the requirements tree.
   Click the Select Req button and expand the requirements tree displayed on the right.

5 Add the Cruise Search requirement to the coverage grid.
   In the requirements tree in the right pane, under Cruise Reservation, select Cruise Search.
Click the **Add to Coverage (Without Children)** button. The **Cruise Search** requirement is added to the coverage grid.

**Tip:** You can also drag a requirement in the requirements tree to the coverage grid. The requirement is added to the coverage grid without its child requirements.

6. **Add coverage to the Cancel All Reservations test.**
   
   In the test plan tree, expand the **Cruises** and **Cruise Cancellation** subject folders, and select the **Cancel All Reservations** test.
   
   In the requirements tree in the right pane, under **Cruise Reservation**, select **Cruise Search** and drag the requirement to the coverage grid. Select **Cruise Booking** and drag the requirement to the coverage grid.

7. **Add coverage to the Airline Preference test.**
   
   In the test plan tree, expand the **Flight Reservation** and **Flight Finder** subject folders, and select the **Airline Preference** test.
   
   In the requirements tree in the right pane, under **Cruise Reservation**, select **Cruise Search** and drag the requirement to the coverage grid. Select **Cruise Booking** and drag the requirement to the coverage grid.

8. **Delete coverage for the Airline Preference test.**
   
   In the coverage grid, select **Flight Tickets**. Click the **Remove Selected** button. Click **Yes** to confirm.
   
   Select **Airline Company** and click the **Remove Selected** button. Click **Yes** to confirm.

9. **Add coverage to the Number of Passengers test.**
   
   In the test plan tree, expand the **Flight Reservation** and **Flight Finder** subject folders, and select the **Number of Passengers** test.
   
   In the requirements tree in the right pane, under **Cruise Reservation**, select **Cruise Search** and drag the requirement to the coverage grid.

10. **Hide the requirements tree.**
    
    Click the **Close** button.
Linking Tests to a Requirement

In this exercise, you will create tests coverage by linking the Cruise Search test to the Cruise Booking requirement.

To link a test to a requirement:

1 Display the Requirements module.
   Click the Requirements button on the sidebar.

2 Display the requirements tree in Requirement Details View.
   Choose View > Requirement Details. The Requirement Details view is displayed.

3 Display the Cruise Booking requirement.
   In the requirements tree, expand the Cruise Reservation folder, and select the Cruise Booking requirement.

4 Display the Test Coverage tab.
   In the right pane, click the Test Coverage tab. The coverage grid indicates that the Cruise Booking requirement is already linked to the following tests: Cruise Booking, Cancel All Reservations, and Airline Preference.
5 Display the test plan tree.

If the test plan tree is not displayed, in the Test Coverage tab, click the Select Tests button to show the test plan tree on the right.

6 Select the Cruise Search test in the test plan tree.

In the Test Plan Tree tab, expand the Cruises and Cruise Reservation subject folders, and select the Cruise Search test.

7 Add the test to the coverage grid.

Click the Add to Coverage button. The Cruise Search test is added to the coverage grid.

Tip: You can also drag a test or a subject folder in the Test Plan Tree to the coverage grid.

8 Hide the test plan tree.

Click the Close button above the test plan tree.
Analyzing Test Coverage

After you create test coverage, you can use the Coverage Analysis view in the Requirements module to analyze the breakdown of child requirements according to test coverage.

In this exercise, you will analyze the Application Client System requirement.

To analyze test coverage:

1. **Make sure that the Requirements module is displayed.**
   
   If the Requirements module is not displayed, click the Requirements button on the sidebar.

2. **Display the requirements tree in Coverage Analysis view.**
   
   Choose View > Coverage Analysis. The Coverage Analysis view is displayed.

3. **Display the Application Client System requirement in Coverage Analysis view.**
   
   If any filters are applied, click the Set Filter/Sort arrow and choose Clear Filter/Sort. Click Yes to confirm.
Under the **Mercury Tours Application** requirement, expand the **Application Client System** requirement and its children.

In the Coverage Analysis column, you can see graphically the number of children that have a direct cover status and those that are not yet covered.

4 **Display coverage analysis for the Application Client System requirement.**

Right-click the **Application Client System** requirement, and choose **Coverage Analysis**. The Coverage Analysis dialog box opens.
5 Display the child requirements with a "Failed" status.

Click the red Failed area of the graph. The child requirements with a "Failed" status are listed.
6 Display test coverage for the requirement.

Click the **Show Test Coverage** link to extend the Coverage Analysis dialog box and display the Test Coverage Chart.

![Coverage Analysis Diagram](image)

This pie chart graphically displays the full test coverage for the requirement, grouped according to test status.

Click the **Passed** section of the chart to open the Tests Coverage dialog box and display the list of tests with the selected status. Close the Test Coverage dialog box.

7 Close the **Coverage Analysis dialog box**.

Click the **Close** button.
Generating Automated Test Scripts

Test planning involves deciding which tests to automate. If you choose to execute tests manually, the tests are ready for execution as soon as you define the test steps. If you choose to automate tests, you can generate test scripts and complete them using other HP testing tools (for example, QuickTest Professional or WinRunner).

Consider these issues when deciding whether to automate a test.

| Do automate: | ➤ Tests that run with each new version of your application to check the stability of basic functionality across the entire application (regression tests).  
➤ Tests that use multiple data values for the same operation (data-driven tests).  
➤ Tests that are run many times (stress tests) and tests that check a multi-user client/server system (load tests). |
| Do not automate: | ➤ Tests that are executed only once.  
➤ Tests that require immediate execution.  
➤ Tests that check how easy the application is to use (usability tests).  
➤ Tests that do not have predictable results. |

In this exercise, you will generate an automated test script for the Address Options test.

To generate an automated test script:

1 Display the Test Plan module.
   Click the Test Plan button on the sidebar.

2 Locate the Address Options manual test.
   Select the Subject folder at the root of the test plan tree and choose Edit > Find. The Find Folder/Test dialog box opens.
   In Value To Find, type Book.
   Select the Include Tests checkbox to search for folders and tests.
   Click Find. The Search Results dialog box opens and displays a list of possible matches.
Double-click the **Flight Reservation\Book Flight** folder to highlight the test in the test plan tree. Click **Close** to close the Search Results dialog box.

In the test plan tree, select the **Address Options** test.

3 **Display the Design Steps tab.**

   In the right pane, click the **Design Steps** tab.

4 **Generate a test script.**

   Click the **Generate Script** button.

   Choose **QUICKTEST_TEST** to generate a QuickTest Professional test, or choose **WR-AUTOMATED** to generate a WinRunner test.

   The steps in the **Address Options** test are used to create an automated test script. In the test plan tree, the manual test with the steps icon next to the test is now replaced with the automated test icon.

5 **View the test script.**

   Click the **Test Script** tab.

   To display and modify your test script in the testing tool in which it was created, click the **Launch** button.
Lesson 4 • Planning Tests
Throughout the application life cycle management process, you can run manual and automated tests to locate defects and assess the quality of your application.

You start by creating test sets and choosing which tests to include in each set. A test set is a group of tests in a Quality Center project designed to achieve specific testing goals. Quality Center enables you to control the execution of tests in a test set by setting conditions and scheduling the date and time for executing your tests.

After you define test sets, you can begin to execute your tests. You can then use Quality Center to view and analyze the results of your tests.

When you run a test manually, you execute the test steps you defined in test planning. You pass or fail each step, depending on whether the actual results match the expected output. When you run a test automatically, Quality Center opens the selected testing tool, which runs the test, and imports the test results to Quality Center.

**In this lesson, you will learn about:**

- Defining Test Sets on page 76
- Adding Tests to a Test Set on page 83
- Scheduling Test Runs on page 85
- Running Tests Manually on page 92
- Viewing and Analyzing Test Results on page 99
- Running Tests Automatically on page 104
Defining Test Sets

After you design tests in the Test Plan module, you create a test sets tree. A test sets tree enables you to organize your testing needs by grouping test sets in folders and organizing them in different hierarchical levels in the Test Lab module. You assign each test set folder to a cycle. This enables you to group together test sets that will be run during the same cycle and analyze the progress of the cycle as you run your tests.

Test sets can include both manual and automated tests. You can also include instances of the same test in different test sets or add more than one instance to the same test set.

To decide which test sets to create, consider the goals you defined at the beginning of the application life cycle management process. Consider issues such as the current state of the application and the addition or modification of new features.

Following are examples of general categories of test sets you can create:

<table>
<thead>
<tr>
<th>Test Set</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Sanity</strong></td>
<td>Checks entire application at a basic level—focusing on breadth, rather than depth—to verify that the application is functional and stable. This set includes fundamental tests that contain positive checks, validating that the application is functioning properly. For example, in the Mercury Tours application, you could test whether the application opens and enables you to log in.</td>
</tr>
<tr>
<td><strong>Regression</strong></td>
<td>Tests the system in a more in-depth manner than a sanity set. This set can include both positive and negative checks. Negative tests attempt to fail an application to demonstrate that the application is not functioning properly.</td>
</tr>
</tbody>
</table>
### Test Set Description

<table>
<thead>
<tr>
<th>Test Set</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Advanced</td>
<td>Tests both breadth and depth. This set covers the entire application, and also tests the application’s advanced options. You can run this set when there is ample time for testing.</td>
</tr>
<tr>
<td>Function</td>
<td>Tests a subsystem of an application. This could be a single feature or a group of features. For example, in the Mercury Tours application, a function set could test all activities related to booking a flight.</td>
</tr>
</tbody>
</table>

In this exercise, you will define the **Mercury Tours Site** test set. You will also set failure rules for the test set to instruct Quality Center how to proceed in the event that an automated test in the test set fails.

**Quality Center Starter Edition:** If you are using Quality Center Starter Edition, fields and commands related to cycles and releases are not available in Quality Center.

---

**To define a test set:**

1. **Open the QualityCenter_Demo project.**
   
   If the **QualityCenter_Demo** project is not already open, log in to the project. For more information, see “Starting Quality Center” on page 17.

2. **Display the Test Lab module.**
   
   Click the **Test Lab** button on the sidebar.
   
   Choose **View > Test Sets Tree** to display test sets in the test sets tree.

3. **Add a folder to the test sets tree.**
   
   In the test sets tree in the left pane, select the **Root** folder.
   
   Click the **New Folder** button. The New Folder dialog box opens.
   
   In the **Folder Name** box, type Service Pack 1 and click **OK**.
Lesson 5 • Running Tests

4 Create subfolders for the test set folder.

Select the Service Pack 1 folder you created and repeat the previous step to create two subfolders, named Cycle 1 - New Features, and Cycle 2 - Full.

5 Assign the test set folders to a cycle.


Select the Cycle 1 - New Features test set folder and click the Assign to Cycle button. The Assign to Cycle dialog box opens.

In the Service Packs releases folder, in the Service Pack 1 release, select the Cycle 1 - New Features cycle.

Click OK. The icon for the folder in the test sets tree changes to show that the folder has been assigned to a cycle.

Right-click the Cycle 2 - Full test sets folder and choose Assign to Cycle. Assign the folder to the Cycle 2 - Full cycle, located in the Service Pack 1 release in the releases tree.
6 Add a test set to the Cycle 1 - New Features test set folder.

In the test sets tree, select **Cycle 1 - New Features**.

Click the **New Test Set** button. The New Test Set dialog box opens.

![New Test Set dialog box](image)

Type the following:

**Test Set Name**: Mercury Tours Site

**Description**: This test set includes tests that verify the functionality of the Mercury Tours site.

Click **OK**. The **Mercury Tours Site** test set is added to the test sets tree in the left pane.
Lesson 5 • Running Tests

7 Define the test set details.

Click the Details tab. By default, the Status indicates that the test set is Open.

<table>
<thead>
<tr>
<th>Details</th>
<th>Execution Grid</th>
<th>Execution Flow</th>
<th>Attachments</th>
<th>Automation</th>
<th>Linked Defects</th>
</tr>
</thead>
<tbody>
<tr>
<td>Baseline</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cycle ID</td>
<td>257</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Open Date</td>
<td>1.23.2009</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Target Cycle</td>
<td>Cycle 1 - New Features</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Perform the following:

**Open Date**: Select a date from the calendar for the planned opening date for the test set.

**Close Date**: Select the planned closing date for the test set.

This test set includes tests that verify the functionality of the Mercury Tours site.
8 Set rules for the automated tests in the test set in the event of a test failure.

Click the **Automation** tab. Click **On Failure**.

Perform the following:

**On automated test failure:** Select the first check box and make sure that the number of times an automated test can be rerun is set to 1.

**On final test failure:** Make sure that the **Do nothing** option is selected.
Lesson 5 • Running Tests

9 Instruct Quality Center to send email to specified users if certain events occur.

Click Notifications.

Perform the following:

**Send email in the event of:** Select the first check box to send email notification if any test in the test set fails.

**To:** Type your email address.

**Message:** Type the following:
This test failed. Please review the test results and submit a defect.
Adding Tests to a Test Set

After you define a test set, you can add test instances to your test set. In this exercise, you will add test instances to the Mercury Tours Site test set.

To add a test to a test set:

1 Make sure the Test Lab module is displayed.

If the Test Lab module is not displayed, click the Test Lab button on the sidebar.

If the Test Sets Tree view is not displayed, choose View > Test Sets Tree.

2 Display the Execution Grid tab.

In the test sets tree, expand the Cycle 1 - New Features test set folder under Service Pack 1. Select the Mercury Tours Site test set.

Click the Execution Grid tab.

3 Display the test plan tree if it is not already displayed.

Click the Select Tests button. The right pane displays the test plan tree.
If any filters are applied, clear them:

In the test plan tree, click the Set Filter/Sort arrow and choose **Clear Filter/Sort**. Click **Yes** to confirm.

In the Execution Grid, click the Set Filter/Sort arrow and choose **Clear Filter/Sort**. Click **Yes** to confirm.

### 4 Add the Cruises folder to the test set.

In the test plan tree, select the **Cruises** folder and click the **Add Tests to Test Set** button.

Click **Yes** to confirm. The Parameters of Test dialog box opens because you are adding a test with an unassigned parameter value to a test set. Click **Cancel** to close the dialog box. You will assign this parameter value when you run the Cruise Booking test (see “Running Tests Manually” on page 92). The tests are added to the test set.

### 5 Add the Airline Preference test to the test set.

To search for the test, in the **Find** box, type **airline** and click the **Find** button. The **Airline Preference** test is highlighted in the test plan tree.

Double-click the **Airline Preference** test. The test instance is added to the test set.

### 6 Add the Number of Passengers test to the test set.

To search for the test, in the **Find** box, type **Number of Passengers** and click the **Find** button. The **Number of Passengers** test is highlighted in the test plan tree.

Drag the **Number of Passengers** test from the test plan tree to the Execution Grid to add it to the test set.

### 7 Close the right pane.

Click the **Close** button.
Scheduling Test Runs

The Execution Flow tab enables you to specify a date and time to execute a test instance and set conditions for it. A **condition** is based on the results of another specified test instance in the Execution Flow. By setting conditions, you can postpone the execution of a test instance until another specified test instance finishes running or passes. You can also set the sequence in which to execute the test instances.

For example, you can schedule Test 2 to run only after Test 1 finishes, and Test 3 to run only if Test 2 passes. You can also schedule Test 1 and Test 2 to run a day before Test 3. The Execution Flow displays the tests and their conditions in a diagram.

A **dashed line** — — arrow indicates a test with no conditions. A **solid line** — — arrow indicates a condition and can be blue or green. If the solid line is blue, it indicates that the condition is set to Finished. If the solid line is green, it indicates that the condition is set to Passed. A **Time Dependency** icon is displayed for time-dependent tests.
Lesson 5 • Running Tests

In this exercise, you will create a new test set and add to it three test instances that verify the login procedure on the Sign-On page of the Mercury Tours site. Then, you will set the conditions for each test instance and specify when each one is to be run.

To schedule a test run:

1 Make sure the Test Lab module is displayed.

If the Test Lab module is not displayed, click the Test Lab button on the sidebar.

Choose View > Test Sets Tree to display test sets in the test sets tree.

2 Create a new test set.

In the test sets tree, choose the Service Pack 1 folder and click the New Test Set button. The New Test Set dialog box opens.

Type the following:

Test Set Name: Test Run Schedule

Description: This test set is used to explain how to schedule a test run.

Click OK. The Test Run Schedule test set is added to the test sets tree in the left pane.
3 Add a test instance from the Sign-On/Sign-Off folder to the Test Run Schedule test set.

Click the Execution Flow tab. If the test plan tree is not open, click the Select Tests button. The test plan tree is displayed in the right pane.

In the Find box in the test plan tree, type sign and click the Find button to search for the Sign-On/Sign-Off folder. The Sign-On/Sign-Off folder is highlighted in the test plan tree.

Select the Sign-On Page test. Click the Add Tests to Test Set button. The Parameters of Test dialog box opens because you are adding a test instance with an unassigned parameter value to a test set. Click Cancel to close the dialog box. The test instance is added to the test set.

4 Add two additional test instances to the test set.

Drag the Sign-On User Name test to the Execution Flow area. The Parameters of Test dialog box opens. Click Cancel.

Double-click the Sign-On Password test to add it to the Execution Flow. The Parameters of Test dialog box opens. Click Cancel.
5 Add an execution condition to the Sign-On User Name test.

Right-click the Sign-On User Name test instance and choose Test Run Schedule. The Run Schedule dialog box opens and displays the Execution Conditions tab.

Click New. The New Execution Condition dialog box opens.

In the Test box, select `<1>Sign-On Page>`. 
Select **Passed** from the list on the right to instruct Quality Center to execute the **Sign-On User Name** test instance only if the **Sign-On Page** test instance finishes executing and passes.

Click **OK**. The condition is added to the Run Schedule dialog box.

**6 Add a time dependency condition to the Sign-On User Name test instance.**

Click the **Time Dependency** tab.
Lesson 5 • Running Tests

Under **Run At Specified Time**, select the **Date** check box and select tomorrow’s date.

Click **OK** to close the Run Schedule dialog box. Your conditions are displayed in the Execution Flow diagram.

7 Add an execution condition to the Sign-On Password test.

Add the same execution condition as described in Step 5 on page 88 for the **Sign-On Password** test. This time select **Sign-On User Name** from the **Test** box in the New Execution Condition dialog box.
8 Add a time dependency condition to the Sign-On Password test.

Add the same time dependency condition as described in Step 6 on page 89 for the Sign-On Password test.

Click **OK** to close the Run Schedule dialog box. Your conditions are displayed in the Execution flow diagram.
Lesson 5 • Running Tests

9 Rearrange the tests in a hierarchical layout.

Click the Arrange Layout button.

Running Tests Manually

When you run a test manually, you follow the test steps and perform operations on your application. Then, you compare the expected results with the actual outcome and record the results. You can execute a manual test as many times as needed. The results are stored separately for each run.

You can run both manual and automated tests manually. You can also choose to run a single test or to run an entire test set.

In this exercise, you will run the Cruise Booking and Cruise Search tests.
Lesson 5 • Running Tests

To run a test manually:

1. Make sure the Test Lab module is displayed.
   If the Test Lab module is not displayed, click the Test Lab button on the sidebar. Click the Execution Grid tab.
   Choose View > Test Sets Tree to display test sets in the test sets tree.

2. Select the Mercury Tours Site test set.
   In the test sets tree, under Service Pack 1, expand the Cycle 1 - New Features test set folder. Select the Mercury Tours Site test set.

3. Select the Cruise Booking test from the Execution Grid.
   In the Execution Grid tab, select Cruise Booking.
   Click the Run button. The Manual Runner dialog box opens.
Lesson 5 • Running Tests

4 Start the test run.

Click the Begin Run button. The Parameters of Test Run dialog box opens because you have an unassigned parameter in the test.
Assign a value for the password parameter.

Click the Actual Value box for password and type the same password you used in Mercury Tours. For more information, see “The Mercury Tours Sample Web Site” on page 24.

Click OK. The Manual Runner dialog box opens.
Lesson 5 • Running Tests

6 Display the Manual Runner dialog box in a compact view.

Click the **Compact view** button. This enables you to read each step individually and record the results.

![Manual Runner dialog box with compact view enabled](image)

7 Perform the first step.

Perform the procedure described in the **Description** box.

If the actual result is the same as the expected result, in the **Actual** box, type:

The Mercury Tours site opens.

Click the **Pass Selected** button. Step 2 is displayed.

8 Perform the second step.

Perform the procedure described in the **Description** box.

If the actual result is the same as the expected result, in the **Actual** box, type:

The Flight Finder page opens.

Click the **Pass Selected** button. Step 3 is displayed.
9 **Perform the third step.**

Perform the procedure described in the **Description** box.

If the actual result is the same as the expected result, in the **Actual** box, type: The Cruise Special page opens.

Click the **Pass Selected** button. Step 4 is displayed.

10 **Perform the fourth step.**

Perform the procedure described in the **Description** box.

If the actual result is different than the expected result, in the **Actual** box, type: The Flight Finder page opens instead of the Cruise Reservation page.

Click the **Fail Selected** button.

---

**Note:** When you detect an application flaw while running the test, you can click the **New Defect** button to open the New Defect dialog box and add a defect. For the purpose of this exercise, you will submit this defect in “Adding New Defects” on page 109.

---

11 **Return to the default display of the Manual Runner.**

Click the **Back to Steps Grid** button. The default display of the Manual Runner: Step Details dialog box is displayed.

12 **End the test run.**

Click the **End Run** button to end your test run.

13 **Run the Cruise Search test.**

In the Execution Grid tab, select the test **Cruise Search** and click the **Run** button. The Manual Runner opens.

Perform the steps for the test as you did for the **Cruise Booking** test, but this time pass each step.
14 View the test run results in the Execution Grid.

Following the execution of your tests, you can view the test run results of your last run in the Execution Grid. Note that the test run status for the **Cruise Booking** test is updated from No Run to Failed and the test run status for the **Cruise Search** test is updated from No Run to Passed.

<table>
<thead>
<tr>
<th>Plan Test Name</th>
<th>Plan Type</th>
<th>Status</th>
<th>Iterations</th>
<th>Plan</th>
</tr>
</thead>
<tbody>
<tr>
<td>[1]Cruise Search</td>
<td>MANUAL</td>
<td>Passed</td>
<td></td>
<td></td>
</tr>
<tr>
<td>[1]Cruise Booking</td>
<td>MANUAL</td>
<td>Failed</td>
<td></td>
<td></td>
</tr>
<tr>
<td>[1]Cancel All Reservations</td>
<td>WR-AUTOMATED</td>
<td>No Run</td>
<td></td>
<td></td>
</tr>
<tr>
<td>[1]Initial Preferences</td>
<td>WR-AUTOMATED</td>
<td>No Run</td>
<td></td>
<td></td>
</tr>
<tr>
<td>[1]Number Of Passengers</td>
<td>QUICKTEST_TEST</td>
<td>No Run</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

15 View the results of each test step in the Last Run Result pane.

Select the **Cruise Booking** test. If the Last Run Result pane is not displayed, click the **Show** button on the bottom of the pane. The Last Run Result pane is displayed below the Execution Grid.

<table>
<thead>
<tr>
<th>Last Run Result</th>
<th>Step Name</th>
<th>Status</th>
<th>Exec Date</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Connect to Mercury</td>
<td>Passed</td>
<td>1/29/2000</td>
</tr>
<tr>
<td></td>
<td>Display the Cruise</td>
<td>Passed</td>
<td>1/29/2000</td>
</tr>
<tr>
<td></td>
<td>Display the Cruise Price</td>
<td>Failed</td>
<td>1/29/2000</td>
</tr>
<tr>
<td></td>
<td>Book the cruise</td>
<td>No Run</td>
<td>1/29/2000</td>
</tr>
<tr>
<td></td>
<td>Print cruise details</td>
<td>No Run</td>
<td>1/29/2000</td>
</tr>
<tr>
<td></td>
<td>Log out</td>
<td>No Run</td>
<td>1/29/2000</td>
</tr>
</tbody>
</table>

Click each step to view its description, as well as the expected and actual results.
Viewing and Analyzing Test Results

Quality Center provides a number of features that enable you to view and analyze the results of your tests.

This section includes:

➤ Viewing Test Results
➤ Viewing Test Coverage
➤ Viewing Coverage Progress

You can also use Quality Center reports and graphs to further analyze your test results. For more information, see “Generating Reports and Graphs” on page 129.

Viewing Test Results

You can view results for a test in the Test Instance Properties dialog box. This includes details of a test’s runs, attachments, linked defects, and history.

In this exercise, you will learn how to view test run information in the Test Instance Properties dialog box.

To view test results:

1 **Make sure the Test Lab module is displayed.**

   If the Test Lab module is not displayed, click the **Test Lab** button on the sidebar.

   Choose **View > Test Sets Tree** to display test sets in the test sets tree.

2 **Display the Mercury Tours Site test set in the Execution Grid.**

   Click the **Execution Grid** tab.

   In the test sets tree, expand the **Cycle 1 - New Features** test set folder under **Service Pack 1**. Select the **Mercury Tours Site** test set.

3 **Select the Cruise Booking test from the Execution Grid.**

   In the Execution Grid tab, select **Cruise Booking**.
Lesson 5 • Running Tests

4 View detailed test results from the Test Instance Properties dialog box.

Click the Test Instance Properties button. The Test Instance Properties dialog box opens and displays the All Runs view.

5 View other test run information in the Test Instance Properties dialog box.

Click Details to view run details of the test.

Click Configuration and select the Manual Parameters tab to view manual parameters for the test. Note that any changes that you make will be implemented in the next test run.

Click Linked Defects to view and manage defect links made to other Quality Center entities.

Click History to view a list of changes made to the test run fields.

6 Close the Test Instance Properties dialog box.

Click the Close button.
Viewing Test Coverage

You previously saw how you can use the Coverage Analysis view to analyze the breakdown of child requirements according to their tests coverage (see “Analyzing Test Coverage” on page 68).

In this exercise, you will learn how to filter the tests included in the coverage analysis by cycle.

Quality Center Starter Edition: This exercise is not available for Quality Center Starter Edition.

To view test coverage:

1. Open the Requirements module in the Coverage Analysis view.
   Click the Requirements button on the sidebar.
   Choose View > Coverage Analysis.

2. Filter the tests included in the coverage analysis by cycle.
   On the upper-right side of the window, click the browse button in the Coverage calculation by cycle box.
   In the releases tree, expand the release folder Service Packs and the release Service Pack 1. Select the Cycle 1 - New Features check box and click OK.
Expand the **Cruise Reservation** requirement. In the Coverage Analysis column, you can see that both sub-requirements have failed. This is because the tests covered by the requirement failed.

**Viewing Coverage Progress**

You were previously introduced to the Progress tab in the Releases module (see “Viewing Releases and Cycles” on page 31). In this exercise, you will view the graphs and statistics that now reflect the results of tests you ran in previous exercises.

**Quality Center Starter Edition:** This exercise is not available for Quality Center Starter Edition.
Lesson 5 • Running Tests

To view coverage progress:

1 Open the Releases module.

Click the Management button on the sidebar and then click the Releases tab.

2 View the effect of your test runs on the Progress tab.

In the releases tree, expand the release folder Service Packs and the release Service Pack 1. Select Cycle 1 - New Features and click the Progress tab.

<table>
<thead>
<tr>
<th>Details</th>
<th>Progress</th>
<th>Quality</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total days in cycle:</td>
<td>29</td>
<td>Days</td>
</tr>
<tr>
<td>Remaining days in cycle:</td>
<td>29</td>
<td></td>
</tr>
<tr>
<td>Total test instances for cycle:</td>
<td>5</td>
<td>Elapsed Remaining</td>
</tr>
<tr>
<td>Remaining test instances to run:</td>
<td>3</td>
<td></td>
</tr>
<tr>
<td>Required execution rate (test instances/day):</td>
<td>0.17</td>
<td>Test Instance Runs</td>
</tr>
<tr>
<td>Actual execution rate (test instances/day):</td>
<td>2.00</td>
<td>Completed Remaining</td>
</tr>
</tbody>
</table>

Coverage Progress
The top pane shows information such as the total and remaining days in the cycle, total test instances for the cycle, and actual and remaining test instances to run.

The bottom pane displays the Coverage Progress graph. **Planned coverage** indicates the percentage of tests planned to be run each day within a cycle. **Executed coverage** indicates the percentage of tests that ran each day within a cycle. **Passed coverage** indicates the percentage of tests that ran successfully each day within a cycle.

### Running Tests Automatically

When you run an automated test, Quality Center automatically opens the selected testing tool, which runs the test on your local machine or on remote hosts, and imports the results to Quality Center.

You can run all tests in a test set or run specific tests. You can run tests from the Execution Grid tab or the Execution Flow tab.

In this exercise, you will run an automated test from the Mercury Tours Site test set.

**To run a test automatically:**

1. **Make sure the Test Lab module is displayed.**
   
   If the Test Lab module is not displayed, click the **Test Lab** button on the sidebar.
   
   Choose **View > Test Sets Tree** to display test sets in the test sets tree.

2. **Display the Mercury Tours Site test set in the Execution Grid.**
   
   Click the **Execution Grid** tab.
   
   In the test sets tree, expand the **Cycle 1 - New Features** test set folder under **Service Pack 1**. Select the **Mercury Tours Site** test set.
Lesson 5 • Running Tests

3 Select a test.

To run a WinRunner test, select **Airline Preference**.

To run a QuickTest Professional test, select **Number of Passengers**.

Click the **Run** button. The Automatic Runner dialog box opens and displays the selected test.

4 Set the test run settings.

Select the **Run All Tests Locally** check box to run the test on your local computer.
Lesson 5 • Running Tests

5 Run the test.

Click the Run button. Quality Center opens the selected testing tool automatically and runs the test. You view the test execution progress in the Status column.

6 Close the Automatic Runner dialog box.

After the test run is complete, choose Run > Exit.

7 View a summary of test results in the Execution Grid.

The Execution Grid displays the updated status for the test run. Results for each test step appear in the Last Run Result pane.

8 Close your selected testing tool.

In QuickTest Professional or WinRunner, choose File > Exit.
Adding and Tracking Defects

Locating and repairing defects is an essential phase in application development. Defects can be detected and submitted by users in all stages of the application life cycle management process. Using Quality Center, you can submit defects detected in the application and track them until they have been repaired and retested.

**In this lesson, you will learn about:**

- How to Track Defects on page 108
- Adding New Defects on page 109
- Matching Defects on page 111
- Updating Defects on page 112
- Linking Defects to Tests on page 116
- Creating Favorite Views on page 118
Lesson 6 • Adding and Tracking Defects

**How to Track Defects**

When you submit a defect to a Quality Center project, it is tracked through these stages: New, Open, Fixed, and Closed. A defect may also be Rejected or it may be Reopened after it is fixed.

When you initially report the defect to a Quality Center project, it is assigned the status **New**, by default. A quality assurance or project manager reviews the defect and determines whether or not to consider the defect for repair. If the defect is refused, it is assigned the status **Rejected**. If the defect is accepted, the quality assurance or project manager determines a repair priority, changes its status to **Open**, and assigns it to a member of the development team. A developer repairs the defect and assigns it the status **Fixed**. You retest the application, making sure that the defect does not recur.

If the defect recurs, the quality assurance or project manager assigns it the status **Reopened**. If the defect is repaired, the quality assurance or project manager assigns it the status **Closed**.
Adding New Defects

You can add a new defect to a Quality Center project at any stage of the application life cycle management process. In this exercise, you will submit the defect that was detected while running the Cruise Booking test.

To add a new defect:

1. **Open the QualityCenter_Demo project.**
   
   If the QualityCenter_Demo project is not already open, log in to the project. For more information, see “Starting Quality Center” on page 17.

2. **Display the Defects module.**
   
   Click the Defects button on the sidebar. The Defects Grid displays defect data in a grid. Each row in the grid displays a separate defect record.

3. **Open the New Defect dialog box.**
   
   Click the New Defect button. The New Defect dialog box opens.
Lesson 6 • Adding and Tracking Defects

4 Describe the defect.
   Perform the following:
   
   **Summary**: Unable to reserve a cruise from the Cruise page.
   
   **Category**: Defect
   
   **Severity**: 2-Medium
   
   **Subject**: Cruises
   
   **Description**: The defect was detected in the Cruise Booking test. When you click the Now Accepting Reservations button, the Flight Finder page opens instead of the Cruise Reservation page.

5 Determine the cycle in which the defect was detected.
   
   **Quality Center Starter Edition**: If you are using Quality Center Starter Edition, proceed to Step 6.
   
   In the **Detected in Cycle** box, click the browse button. The releases tree opens. Expand the tree. In the **Service Packs** releases folder, in the **Service Pack 1** release, select the **Cycle 1 - New Features** cycle.
   
   You can see that Quality Center automatically assigns the value **Service Pack 1** to the **Detected in Release** field. This is because **Cycle 1 - New Features** is part of the **Service Pack 1** release.
   
   Click **OK** to close the releases tree.

6 Attach the URL address for the Mercury Tours page where the defect was detected.
   
   Click the **Attach URL** button. The Attach Uniform Resource Locator (URL) dialog box opens.
   
   Type the URL address of the Mercury Tours page: `http://<Quality Center server name>/mtours`
   
   Click **OK**. The URL name is displayed above the **Description** box.

7 Add the defect to the Quality Center project.
   
   Click the **Submit** button. The defect is added to the Defects Grid.

8 Close the New Defect dialog box.
   
   Click **Close**.
Matching Defects

Matching defects enables you to eliminate duplicate or similar defects in your project. Each time you add a new defect, Quality Center stores lists of keywords from the Summary and Description fields. When you search for similar defects, keywords in these fields are matched against other defects. Note that keywords must be more than two characters and letter case does not affect your results.

In this exercise, you will match defects by comparing a selected defect with all other existing defects in the QualityCenter_Demo project.

To match defects:

1. Make sure that the Defects module is displayed.
   - If the Defects module is not displayed, click the Defects button on the sidebar.

2. Select Defect ID 37.
   - If a filter is applied to the grid, click the Set Filter/Sort arrow and choose Clear Filter/Sort to clear the filter.
   - In the Defects Grid, select Defect ID 37.

3. Find similar defects.
   - Click the Find Similar Defects button.
The results are stored in the Similar Defects dialog box, sorted by the percentage of detected similarity. Note that there are no duplicate defects in the project for the selected defect.

Click **Close** to close the Similar Defects dialog box.

**Updating Defects**

Tracking the repair of defects in a project requires that you periodically update defects. You can do so directly in the Defects Grid or in the Defect Details dialog box. The ability to update some defect fields depends on your permission settings. After you have updated defects, you can view the current quality status of your release in the Release module.

In this exercise, you will update your defect information by changing the severity of a defect, assigning the defect to a cycle, and adding a comment. You will then see how updating defects is reflected in the Quality tab of the Releases module.
Quality Center Starter Edition: If you are using Quality Center Starter Edition, fields and commands related to cycles and releases are not available in Quality Center.

To update defects:

1 Make sure that the Defects module is displayed.
   If the Defects module is not displayed, click the **Defects** button on the sidebar.

2 Open the Defect Details dialog box.
   In the Defects Grid, select the defect you added in “Adding New Defects” on page 109. Click the **Defect Details** button. The Defect Details dialog box opens.
Lesson 6 • Adding and Tracking Defects

3 Change the severity level of the defect.
   In the Severity box, select 5-Urgent.

4 Determine the cycle in which the defect will be fixed.
   Quality Center Starter Edition: If you are using Quality Center Starter Edition, proceed to Step 5.

   In the Target Cycle box, click the browse button. The releases tree opens. Expand the tree. In the Service Packs releases folder, in the Service Pack 1 release, select the Cycle 2 - Full cycle.

   You can see that Quality Center automatically assigns the value Service Pack 1 to the Target Release field. This is because the Cycle 2 - Full cycle is part of the Service Pack 1 release.

   Click OK to close the releases tree.

5 Add a new comment to explain the change in the severity level.
   Click the Add Comment button. A new section is added to the Comments box, displaying your user name and the current date.

   Type: This defect should be fixed in the next service pack.

6 View the Attachments.
   Click Attachments on the sidebar. Note that the URL attachment is listed.

7 View Linked Entities.
   Click Linked Entities on the sidebar to view entities that have been linked to the defect. Linked Entities can include requirements, tests, test sets, test instances, runs, run steps, and other defects. There are currently no linked entities. You will learn how to link a defect to a test in “Linking Defects to Tests” on page 116.

8 View the History.
   Click History on the sidebar to view the history of changes made to the defect. For each change, the grid displays the date and time of the change and the name of the user who made the change. You can expand a change to view a list of fields modified during the change. For each field, the grid displays the old value and the new value.
9 Close the Defect Details dialog box.
   Click OK to exit the dialog box.

10 Update defects directly in the Defects Grid.
   **Quality Center Starter Edition:** If you are using Quality Center Starter Edition, ignore this step.
   
   In the Defects Grid, select defect ID 23.
   
   Click the **Detected in Cycle** box and click the drop-down arrow. In the releases tree, expand the release folder **Service Packs** and the release **Service Pack 1**. Select the **Cycle 1 - New Features** cycle and click **OK**.
   
   Click the **Target Cycle** box and click the browse button. In the releases tree, expand the release folder **Service Packs** and the release **Service Pack 1**. Select the **Cycle 1 - New Features** cycle and click **OK**.

11 Update defects 35 and 36.
   **Quality Center Starter Edition:** If you are using Quality Center Starter Edition, ignore this step.
   
   Repeat step 10 for defects 35 and 36.

12 View the number of defects opened in Cycle 1 - New Features on the Quality tab.
   **Quality Center Starter Edition:** If you are using Quality Center Starter Edition, ignore this step.
   
   Click the **Management** button on the sidebar. In the Releases tab, expand the release folder **Service Packs** and the release **Service Pack 1**, and select the cycle **Cycle 1 - New Features**. Click the **Quality** tab.
   
   In the **Defect Opening Rate** graph, you can see the defects detected in **Cycle 1 - New Features** according to defect severity.
   
   In the **Outstanding Defects** graph, you can see the outstanding defects in **Cycle 1 - New Features** according to defect status.
Linking Defects to Tests

You can link a test in your test plan to a specific defect in the Defects Grid. This is useful, for example, when a new test is created specifically for a known defect. By creating linkage, you can determine if the test should be run based on the status of the defect. Note that you can also link the defect to other entities, such as requirements.

A defect can be linked directly or indirectly to an entity. When you add a defect link to an entity, Quality Center adds a direct link to this entity and indirect links to other related entities.

The following diagram illustrates the flow of indirect linkage:

For instance, when you link a defect to a run step, it adds an indirect link to its run, test instance, test set, and test. If the same test is covered by a requirement, an indirect link is also added to the requirement. Note that the indirect linkage is a one-directional flow. For example, if you link a defect to a run, it is not indirectly linked to its run steps.

In this exercise, you will link your defect to the Cruise Booking test in the Test Plan module, and view the linked test in the Defects Grid.

To link a defect to a test:

1. Display the Test Plan module.
   - Click the Test Plan button on the sidebar.

2. Select the Cruise Booking test.
   - In the test plan tree, under Cruises, expand Cruise Reservation and select the Cruise Booking test. Click the Linked Defects tab.
3 Add a linked defect.

In the Linked Defects tab, click the Link Existing Defect arrow and choose Select. The Defects to Link dialog box opens.

Select the defect you added in “Adding New Defects” on page 109 and click the Link button. Your defect is added to the Linked Defects grid.

Note: If you cannot find your defect in the Defects to Link dialog box, click the Set Filter/Sort arrow and choose Clear Filter/Sort to clear the filter that is applied to the grid.
Lesson 6 • Adding and Tracking Defects

4 View the linked test in the Defects Grid.

Click the Defects button on the sidebar.

Double-click your defect in the Defects Grid. The Defect Details dialog box opens.

Click Linked Entities on the sidebar, and select the Others tab. The Cruise Booking test is linked to your defect.

Click OK to close the Defect Details dialog box.

Creating Favorite Views

A favorite view is a view of a Quality Center window with the settings you applied to it. For example, in the Defects Grid, you may want to apply a filter to display only the defects that were detected by you, are assigned to you, or have the status “Not Closed”.

In this exercise, you will create a favorite view in the Defects Grid.

To create a favorite view:

1 Make sure that the Defects module is displayed.

If the Defects module is not displayed, click the Defects button on the sidebar.
2 Define a filter to view defects you detected that are not closed.

Click the **Set Filter/Sort** button. The Filter dialog box opens.

For the **Detected By** field, click the **Filter Condition** box. Click the browse button. The Select Filter Condition dialog box opens.
Lesson 6 • Adding and Tracking Defects

Under **Name**, select your Quality Center login user name (alice_qc, cecil_qc, or michael_qc). Click **OK** to close the Select Filter Condition dialog box.

For the **Status** field, click the **Filter Condition** box. Click the browse button. The Select Filter Condition dialog box opens.

In the right pane, click the logical expression **Not**.

In the left pane, select **Closed**.

![Select Filter Condition dialog box](image)

Click **OK** to close the Select Filter Condition dialog box.

Click **OK** to apply your chosen filter.

The Defects Grid displays the defects you detected that are not closed.

3 Add a favorite view.

In the **Favorites** menu, choose **Add to Favorites**. The Add Favorite dialog box opens.

![Add Favorite dialog box](image)

In the **Name** box, type: *My detected defects (status ‘Not Closed’)*.

You can add a favorite view to either a **public** folder or a **private** folder. Views in the public folder are accessible to all users. Views in the private folder are accessible only to the person who created them. Select **Private**.
Lesson 6 • Adding and Tracking Defects

Click **OK**. The new view is added to your private folder.

<table>
<thead>
<tr>
<th>Favorites</th>
<th>Analysis</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add to Favorites…</td>
<td></td>
</tr>
<tr>
<td>Organize Favorites…</td>
<td></td>
</tr>
<tr>
<td>Private</td>
<td>My detected defects (status 'Not Closed')</td>
</tr>
</tbody>
</table>
Lesson 6 • Adding and Tracking Defects
Alerting on Changes

You can instruct Quality Center to create alerts automatically and send email to notify those responsible when certain changes occur in your project that may impact the application life cycle management process. You can also add your own follow-up alerts.

To generate automatic notification alerts, your Quality Center project administrator must activate alert rules in Project Customization. Alert rules are based on associations you make in Quality Center between requirements, tests, and defects. When an entity in your project changes, Quality Center alerts any associated entities that may be impacted by the change. The alerts can be seen by all users. Quality Center also notifies the person responsible for the entity at the time of the change of any associated entities that may be impacted by the change.

Quality Center also enables you to add your own follow-up flag to a specific requirement, test, test instance, or defect to remind you to follow up on an issue. When the follow-up date arrives, Quality Center sends you an email reminder.

In this lesson, you will learn about:

➤ Triggering an Alert on page 124
➤ Creating Follow Up Alerts on page 126
Lesson 7 • Alerting on Changes

Triggering an Alert

When a requirement, test, test instance, or defect in your project changes, Quality Center can notify those responsible for any associated entities. You can associate tests with requirements (see “Creating and Viewing Requirements Coverage” on page 63) and defects with other Quality Center entities (see “Linking Defects to Tests” on page 116). In addition, you can create traceability links between requirements. For more information on creating traceability links between requirements, see the HP Quality Center User Guide.

Quality Center can generate alerts for these changes:

<table>
<thead>
<tr>
<th>What changed?</th>
<th>Which associated entities are flagged?</th>
<th>Who is notified?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Requirement (excluding change of status)</td>
<td>Tests</td>
<td>Test designers</td>
</tr>
<tr>
<td></td>
<td>Requirements</td>
<td>Requirement authors</td>
</tr>
<tr>
<td>Defect status changed to Fixed</td>
<td>Test instances</td>
<td>Responsible testers</td>
</tr>
<tr>
<td>Test runs successfully</td>
<td>Defects</td>
<td>Users assigned to defects</td>
</tr>
</tbody>
</table>

In this exercise, you will trigger alerts for tests by changing the associated requirement. You will modify the Cruise Booking requirement and then you will view the flagged tests.

To trigger an alert:

1 Display the requirements tree.

   Click the Requirements button on the sidebar, and choose View > Requirement Details.

2 Select the requirement that you want to change.

   Under Cruise Reservation, select the Cruise Booking requirement.

3 View the associated tests.

   To view the tests that will be impacted by the change, click the Test Coverage tab. The tab displays the associated tests.
4 Change the priority of the Cruise Booking requirement.

Click the Details tab.

Click the down arrow adjacent to the Priority box and select 5-Urgent.

This change causes Quality Center to generate alerts for the tests associated with this requirement. Quality Center also sends email notification to the designers of these tests.

5 View the alert for the Cruise Booking test.

In the Test Coverage tab, click the Cruise Booking test. The test is highlighted in the test plan tree.

Click the Refresh All button.

The Cruise Booking test has an alert flag !, indicating that a change was made to an associated requirement.

Click the Alerts flag for the Cruise Booking test. The Alerts dialog box opens.

The alert indicates the requirement and the change that triggered the alert. It also indicates the name of the person to whom Quality Center sends email notification of this change.

Click the close button.
6 View the alerts of the other associated tests.

In the test plan tree, view the alerts of the following tests: Cruise Search, Cancel All Reservations, and Airline Preference.

Creating Follow Up Alerts

Quality Center enables you to add your own alerts to remind you to follow up on outstanding issues. In this exercise, you will add a follow-up flag to a defect whose status you want to check one week from today.

When you add a follow-up flag, Quality Center also adds an information bar that reminds you about the follow-up alert. When the follow-up date arrives, Quality Center sends you an email reminder and changes the flag icon from gray to red.

Follow-up flags are specific to your user name, meaning that only you can see your follow-up alerts.

To create a follow up alert:

1 Display the Defects module.

Click the Defects button on the sidebar.

2 Select the defect that you want to flag with a follow up reminder.

In the Defects Grid, select a defect.
3 Create the follow up alert.

Click the **Flag for Follow Up** button. The Flag For Follow Up dialog box opens.

Perform the following:

**Follow up by:** Select the date one week from today.

**Description:** Type: Remind me about this defect on this date.

Click **OK**. The flag icon is added to the defect record.
4 Display the information bar for your follow up alert.

Double-click the defect with the follow up flag. The Defect Details dialog box opens and displays an information bar with your follow up alert.

Click **Cancel** to close the dialog box.
Generating Reports and Graphs

Quality Center reports and graphs help you assess your application life cycle management process. You can generate reports and graphs at any time during the process.

You can create reports and graphs either in the Dashboard module, or during your work in the Requirements, Test Plan, Test Lab, or Defects modules. In either case, you can save the reports and graphs in the Dashboard module for future reference.

Using the Dashboard module, you can also create dashboard pages that display multiple graphs side-by-side.

In this lesson, you will learn about:
- Generating Reports on page 130
- Generating Graphs on page 138
- Generating Dashboard Pages on page 145
Generating Reports

You can create reports in the Dashboard module that display data from the Requirements, Test Plan, Test Lab, and Defects modules. You can also create quick reports directly from the Requirements, Test Plan, Test Lab, and Defects modules.

This section includes:

➤ Generating Reports in the Dashboard Module
➤ Generating Quick Reports

Generating Reports in the Dashboard Module

You create reports in the Dashboard module and you can determine what data to include.

Reports are placed in either a public folder or a private folder. Reports in a public folder are accessible to all users. Reports in a private folder are accessible only to the user who created them.

In this exercise, you will create and configure a requirement report using the Dashboard module.

To generate a report in the Dashboard module:

1 Open the QualityCenter_Demo project.
   If the QualityCenter_Demo project is not already open, log in to the project. For more information, see “Starting Quality Center” on page 17.

2 Display the Dashboard module.
   Click the Dashboard button on the sidebar to display the Dashboard module.
   If the Analysis View tab is not already displayed, click the Analysis View tab.
3 Add a folder to the Private root folder.
   In the tree, select the Private folder.
   Click the New Folder button. The New Folder dialog box opens.
   In the Folder Name field, type Requirements.
   Click OK. The new folder is added as a sub-folder of the Private folder. The Details tab displays the folder name and the user that created the folder.
   In the Description tab, type This folder includes requirement reports.

4 Create a report.
   Under Entity, select Requirements.
   Under Standard Report Name, type Requirement report.
   Click OK. The report is added to the private folder.

5 Add report description.
   Click the Details tab.
   In the Description field, type This is my private requirement report.
Lesson 8 • Generating Reports and Graphs

6 Display the customization options.

Click the Configuration tab.

Using the Configuration tab, you can determine the appearance and contents of your Quality Center reports.

7 Set the number of items per display page.

Under Page, select All items in one page to display all items in one page.
8 Define a filter to view requirements created by a specific user name.

Under **Filter**, click the **Set Filter/Sort** button. The Filter dialog box opens.

For the **Author** field, click the **Filter Condition** box. Click the browse button. The Select Filter Condition dialog box opens.

Under **Name**, select your Quality Center login user name (**alice_qc**, **cecil_qc**, or **michael_qc**). Click **OK** to close the Select Filter Condition dialog box.

Click **OK** to close the Filter dialog box.

9 Display the report as a grid.

Under **Options**, select **Grid View**.
10 Generate the report.

Click the View tab to generate a report with the updated settings.

This report lists the requirements that appear in the current requirements view by the specified author.
Generating Quick Reports

Quick reports are reports that display data in the Requirements, Test Plan, Test Lab and Defects modules. When you create quick reports, you can choose from a list of predefined reports, or you can create reports on selected records for immediate display.

You can use quick reports for one-time reference, or save them in the Dashboard module, where you can continue to configure their data and appearance.

In this exercise, you will generate a standard report from the Requirements module and save it in the Dashboard module.

To generate a quick report:

1 Display the Requirements module.

Click the Requirements button on the sidebar to display the Requirements module.

If the Requirements Tree view is not already displayed, choose View > Requirements Tree.
Lesson 8 • Generating Reports and Graphs

2 Generate the report.


This report lists the requirements that appear in the current requirements view.
3 Save the report in the Dashboard module.

Click Save. The New Standard Report dialog box opens.

Under Select Folder, select Private. Click Save.

The Dashboard module opens in the Analysis View, and the report opens under the View tab.
Generating Graphs

You can create graphs in the Dashboard module, that display data from the Requirements, Test Plan, Test Lab, and Defects modules. You can also create quick graphs directly from the Requirements, Test Plan, Test Lab, and Defects modules. In either case, you can use a graph wizard to guide you through the stages of creating a graph.

This section includes:

➤ Generating Graphs in the Dashboard Module
➤ Generating Quick Graphs

Generating Graphs in the Dashboard Module

In the Dashboard module, you can create graphs and configure them according to your specifications. You can also create a graph using the graph wizard. The graph wizard takes you through the steps involved in creating a graph and defining its settings.

You create graphs in either a public folder or a private folder. Graphs in a public folder are accessible to all users. Graphs in a private folder are accessible only to the user who created them.

In this exercise, you will use the graph wizard to generate a graph that summarizes the defects by status and priority level.

To generate a graph in the Dashboard module:

1 Make sure the Dashboard module is displayed

If the Dashboard module is not displayed, click the Dashboard button on the sidebar to display the Dashboard module.

If the Analysis View tab is not displayed, click the Analysis View tab.
2 Open the graph wizard.

Click the **New Item** button and select **Graph Wizard**. The graph wizard opens on the Select Graph Type dialog box.

![Graph Wizard](image)

3 Select the graph type.

Under **Entity**, select **Defects**.

Under **Graph Type**, make sure **Summary** is selected.

Click **Next**. The Select Filter dialog box opens.

![Select Filter](image)
4 Define a filter to view defects with high to urgent priority.

Under Filter Selection, select Define a new filter. Click the Filter button. The Filter dialog box opens.

For the Priority field, click the Filter Condition box. Click the browse button. The Select Filter Condition dialog box opens.

In the right pane, select the logical expression \(\geq\).

In the left pane, select **3-High**.

Click **OK** to close the Select Filter Condition dialog box.

5 Define a filter to view defects that are not closed.

For the Status field, click the Filter Condition box. Click the browse button. The Select Filter Condition dialog box opens.

In the right pane, select the logical expression **Not**.

In the left pane, select **Closed**.

Click **OK** to close the Select Filter Condition dialog box.

Click **OK** to close the Filter dialog box.
Click Next. The Select Graph Attributes dialog box opens.

6 Set the graph attributes.

Under **Group By field**, make sure that it is set to **None**.

Under **X-axis field**, select **Priority** to view the number of defects by priority.

Click **Next**. The Select Name and Folder dialog box opens.
Lesson 8 • Generating Reports and Graphs

7 Define the graph name and its location in the analysis tree.
Under Graph Name, accept the default name.
Under Destination Folder, make sure that the Private folder is selected.

8 Generate the Graph.
Click Finish. The graph is displayed in the View tab.

The graph shows a summary of defects with high to urgent priority in which their defect status is not closed.
Lesson 8 • Generating Reports and Graphs

9 Display additional defect details.
Click a bar in the graph. The Drill Down Results dialog box opens and displays the defects that belong to the bar.

![Drill Down Results dialog box]

Close the Drill Down Results dialog box.

10 Display other graph views.
Click the Pie Chart button to display the graph as a pie chart.
Click the Data Grid button to display the data as a grid.

Generating Quick Graphs
You can create quick graphs during your work in the Requirements, Test Plan, Test Lab, and Defects modules. Quick graphs enable you to create several types of graphs in each module, using the existing module filter. You can use quick graphs for one-time reference, or save them in the Dashboard module, where you can continue to configure their data and appearance.

In this exercise, you will generate a summary graph from the Defects module.

To generate a quick graph:

1 Display the Defects module.
Click the Defects button on the sidebar to display the Defects module.
2 Generate the report.

Choose **Analysis > Graphs > Defects Summary Group by Status**. The Defects Summary - Group by Status dialog box opens.

![Defects Summary - Group by Status dialog box]

The graph shows the number of defects that exist in your project, according to the people to whom they are assigned. Defects in the graph’s columns are grouped according to their status.

3 Close the Defects Summary - Group by Status dialog box.

Click the **Cancel** button.
Generating Dashboard Pages

Using the Dashboard module, you can arrange and view multiple graphs on a single dashboard page. You select the graphs to include in the dashboard page from the graphs in the analysis tree. You can arrange and resize the graphs on the page.

You create dashboard pages in either a public folder or a private folder. Dashboard pages in a public folder are accessible to all users. Dashboard pages in a private folder are accessible only to the user who created them.

In this exercise, you will create a dashboard page for the defect graphs in the public folder.

---

**Note:** The user name that you logged in to Quality Center does not have the required permission to create dashboard pages. To perform this exercise, you will log in using a different user name.

---

**To generate a dashboard page:**

1. **Log out and log in as a different user.**

   Click the **Logout** button on the upper right-side of the window. The HP Quality Center Login window opens.

   In the **Login Name** box, type **alex_qc**.

   Skip the **Password** box. A password was not assigned to this user name.

   Click the **Authenticate** button. Quality Center verifies your user name and password and determines which domains and projects you can access.

   In the **Domain** list, select **Default**.

   In the **Project** list, select **QualityCenter_Demo**.

   Click the **Login** button. The Quality Center main window opens and displays the module in which you were last working.
Lesson 8 • Generating Reports and Graphs

2 Make sure the Dashboard module is displayed

If the Dashboard module is not displayed, click the Dashboard button on the sidebar to display the Dashboard module.

Click the Dashboard View tab.

3 Add a page to the Public folder.

In the tree, select the Public folder.

Click the New Page button. The New Dashboard Page dialog box opens.

In the Dashboard Page Name field, type Summary of Defects page.

Click OK. A dashboard page is added to the dashboard tree under the Public folder.

4 Select the graphs that you want to include in the dashboard page.

Click the Configuration tab.

In the Graphs Tree pane, expand the Public folder.

Expand the Defects folder. The folder includes four graphs.

![Graphs Tree](image)

Double-click the first graph. A placeholder for the graph is created in the Configuration tab displaying the graph’s title.
Add the other three graphs to the dashboard page.
5 Rearrange the dashboard page.

Select the second placeholder and drag it upwards so that it is alongside the first placeholder.

Select the fourth placeholder and drag it upwards so that it is alongside the third placeholder.
6 View the dashboard page.

Click the View tab. Quality Center generates and displays the graphs in the View tab.

The dashboard page displays the unresolved defects per cycle, per person, per severity, and per subject.

To view the dashboard page in full-screen mode, click the View Page in Full Screen button, located in the upper-right corner of the page.

To return to the standard view, click the close button, located in the upper-right corner of the page.
Creating Libraries and Baselines

You create libraries in the Libraries module. After you create a library, you can create and compare baselines for the library to track changes in your project over time.

A library represents a set of entities in a project and the relationships between them. The entities in a library can include requirements, tests, test resources, and business components. A baseline is a snapshot of the library at a specific point in time. Baselines enable you to keep track of changes made to your project over time.

You can compare baselines at all stages of the application life cycle management process. For example, you can compare two baselines in a library to review changes made to tests in the library over time. You can also compare a baseline to the current entities in the library.

In this lesson, you will create a library of tests and requirements. You will then compare two baselines in the library to review changes made to tests in the library over time.

Quality Center Starter Edition: This lesson is not available for Quality Center Starter Edition.

In this lesson, you will learn about:

➤ Creating Libraries on page 152
➤ Creating Baselines on page 154
➤ Comparing Baselines on page 157
Creating Libraries

In this exercise, you will add a library of tests and requirements to Quality Center. To perform this exercise you must log in as alex_qc.

To create a library:
1 Make sure to log in to QualityCenter_Demo as alex_qc.

Open the HP Quality Center Login window. In the Login Name box, type alex_qc. Skip the Password box.

For more information, see “Starting Quality Center” on page 17.

2 Display the Libraries module.

Click the Management button on the sidebar and then click the Libraries tab.

3 Create a library folder.

In the libraries tree, select the root Libraries folder. Click the New Folder button. The New Library Folder dialog box opens.

In the Library Folder Name box, type Folder1.

Click OK. The Folder1 folder is added to the libraries tree.

In the Description box in the right pane, type the following description for the library folder: This folder contains a library of tests and requirements.
4 Add a library to your library folder.

   Click the Create Library button. The Create Library dialog box opens.

   ![Create Library dialog box](image)

   In the Name box, type Library1.

   Under Select Entities, in the Requirement Root Folder box, click the browse button. Select the Mercury Tours Application folder to include in the library. Click OK.

   In the Test Root Folder box, click the browse button. Under Subject, select the Mercury Tours Site folder to include in the library. Click OK.

   In the Description box, type This library includes tests and requirements.

   Click OK. The new library is added to the libraries tree.
Creating Baselines

A baseline is a snapshot of your library at a specific point in time. You can use a baseline to mark any significant milestone in the application life cycle management process. A baseline includes all the entities defined in the library, including requirements, tests, and test resources. Baselines also include the relationships between the entities in the library, such as traceability and coverage. Baselines enable you to keep track of changes made to your project over time.

In the following exercise, you will create an initial baseline that will later be compared to another baseline to evaluate the impact of changes.

To create a baseline:

1. **Make sure the Libraries module is displayed.**
   
   If the Libraries module is not displayed, click the Management button on the sidebar and then click the Libraries tab.

2. **Add a baseline to your library.**
   
   In the libraries tree, select the Library1 library.

   Click the Create Baseline button. A verification process begins.

   For each entity in the library that is associated with another entity in the project, Quality Center verifies that the associated entity is also contained in the library. For example, for each test that has requirements coverage, Quality Center checks if the associated requirement is also contained in the library.
Lesson 9 • Creating Libraries and Baselines

If there are entities in the library that are associated with entities not contained in the library, Quality Center creates a list of these entities, and the Broken Links Verification dialog box opens.

Click Continue. The New Baseline dialog box opens.

In the Baseline Name field, type Baseline1. Click OK.
The baseline is added to the libraries tree, and the creation process begins.

The baseline is created in a background process, and may take some time. You can continue working in Quality Center during the baseline creation process.

In the Details tab, click the **Description** pane and type **Baseline of tests and requirements**.

**3 View the baseline log file.**

In the Details tab, click the **View Log** button. The Log: Create Baseline dialog box opens and displays progress. Click **Close** to close the dialog box.

The View Log button is no longer displayed.
Comparing Baselines

You can compare two baselines in a library. For example, you can compare baselines at different stages of development to assess the impact of changes made to requirements in your project. You can then update the relevant tests in your project accordingly.

You can also compare a baseline to the current entities in the library. For example, suppose you create a baseline at the start of a new release. Over time, changes are made to requirements in the library. To determine whether product development is proceeding as planned, you can compare requirements in the initial baseline with the current requirements in the library.

In the following exercise, you will add test coverage to a requirement and then create another baseline. You will then compare your two baselines to evaluate the impact of the changes.

To compare baselines:

1 Modify a requirement.
   
   Click the Requirements button on the sidebar to display the Requirements module.

   In the requirements tree, under Mercury Tours Application, expand Application Usability. Select Keyboard Support.

   Click the Test Coverage tab. The Test Coverage tab displays coverage for this requirement.

   If the Test Plan Tree tab on the right is not displayed, click the Select Tests button.

   In the Test Plan Tree tab, expand the Mercury Tours Site and HTML Pages subject folders.

   Double-click the HTML Page Source test. The test is added to the coverage grid.

2 Create a new baseline.
   
   Repeat Steps 1 and 2 on page 154. Name your new baseline Baseline2.
3 Select a baseline with which to compare.

In the libraries tree, select **Baseline1**. Click the **Compare To** button, and select **Select Baseline** to compare the baseline with another baseline. The Select Baseline dialog box opens.

Click the browse button and select **Baseline2** from the list. Click **OK**.

Click **OK** to close the Select Baseline dialog box. The Compare Baselines Tool dialog box opens.

The baselines are displayed in separate panes, with the more recently created baseline displayed in the right pane. In each pane, the library’s entities are displayed in the same hierarchical tree structure as defined in the specific module.
Lesson 9 • Creating Libraries and Baselines

4 View requirement changes between the baselines.

Click the Go to Next Change button in the right pane to view the change.

Differences between the two baselines are indicated in the Changes column. The tool indicates that there is a difference in the Keyboard Support requirement between the baselines.

To compare the modified requirement between baselines, select Keyboard Support and click the Compare Entities button on the toolbar. The Compare Entities dialog box opens.
Click the **Test Coverage** button on the sidebar.

The Test Coverage view displays details of the entity in each baseline. Click **Close**.
5 View test changes between the baselines.

In the Compare Baselines Tool dialog box, click the Tests button on the sidebar.

Click the Go to Next Change button in the right pane to view the change.

The tool indicates that there is a difference in the HTML Page Source test between the baselines.

Click Close to close the Compare Baselines Tool dialog box.
Customizing Projects

In the previous lessons, you learned how to use Quality Center to help you manage all phases of the application life cycle management process, including specifying releases and cycles, specifying requirements, planning tests, running tests, and tracking defects.

In this lesson, you will learn how to customize your Quality Center project to meet the needs of your team. You can control access to a project by defining the users who can access the project and by specifying the types of tasks each user can perform. When new members are added to your team, you assign them to the projects that they will be using, and specify the tasks that they can perform.

You can also customize your Quality Center project by modifying system fields or by adding user-defined fields. **System fields** are Quality Center default fields. You cannot add or delete system fields, you can only modify them. **User fields** are fields that you can define. You can add, modify, and delete user-defined fields.

Fields can be associated with system and user-defined lists. A list contains the values that the user can enter in a field. For example, if you are running tests on two different database servers, you can add a **Database** field to your project. You can then create a selection list containing the values **Oracle** and **Microsoft SQL**, and associate the list with the **Database** field.
Lesson 10 • Customizing Projects

In this lesson, you will learn about:
➤ Starting Project Customization on page 164
➤ Adding a New Project User on page 167
➤ Assigning a User to a User Group on page 169
➤ Defining a User-Defined Field on page 171
➤ Creating a Project List on page 174

Starting Project Customization

You customize your Quality Center projects using the Project Customization window. In this exercise, you will log in to the Project Customization window with project administrator privileges.

To start project customization:

1 Open the HP Quality Center Login window.
Make sure that the HP Quality Center Login window is open. For more information, see “Starting Quality Center” on page 17.

2 Type a user name with project administrator privileges and authenticate.
In the Login Name box, type alex_qc.
Skip the Password box. A password was not assigned to this user name.
Click the Authenticate button. Quality Center verifies your user name and password and determines which domains and projects you can access.

3 Log in to the project.
In the Domain list, select Default.
In the Project list, select QualityCenter_Demo.
Click the Login button.
The Quality Center main window opens and displays the module in which you were last working.
4 Open the Project Customization window.

Choose **Tools > Customize** on the upper-left corner of the Quality Center window. The Project Customization window opens.

By default, the Project Customization window contains the following links:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>User Properties</td>
<td>Enables you to change your user properties. For example, you can change your email address. You can also change your password.</td>
</tr>
<tr>
<td>Project Users</td>
<td>Enables you to add and remove users from a Quality Center project. You can also assign users to user groups to restrict user access privileges.</td>
</tr>
<tr>
<td>Groups</td>
<td>Enables you to assign privileges to user groups by specifying permission settings.</td>
</tr>
</tbody>
</table>
## Module Access
Enables you to control the modules that each user group can access. By preventing users from accessing unnecessary modules, you can better utilize your Quality Center licenses.

## Project Entities
Enables you to modify the behavior of Quality Center system fields or define user-defined fields that are unique to your project. For example, if you are running tests on several builds of an application, you can add a **Detected in Build** user-defined field to the New Defect dialog box. You can then associate it with a selection list containing the values for this field.

## Requirement Types
Enables you to customize the definitions for requirement types.

**Quality Center Starter Edition:** This option is not available for Quality Center Starter Edition.

## Risk-Based Quality Management
Enables you to customize settings for risk-based quality management.

**Quality Center Starter Edition:** This option is not available for Quality Center Starter Edition.

## Project Lists
Enables you to add customized lists to a project. A list contains values that the user can enter in system or user-defined fields. For example, for the **Detected in Build** field, you can create a selection list containing the values Build1, Build2, and Build3.

## Automail
Enables you to set up automatic mail notification rules to inform users via email each time changes are made to specified defects.

## Alert Rules
Enables you to activate alert rules for your project. This instructs Quality Center to create alerts and send emails when changes occur in the project.

## Workflow
Enables you to generate scripts to perform commonly needed customizations on the fields of the Defects module dialog boxes. In addition, you can write scripts to customize dialog boxes in any module, and to control the actions that users can perform.
Adding a New Project User

You can control access to a Quality Center project by defining the users who can log in to the project, and by specifying the types of tasks each user may perform.

For each project, you select project users from the Quality Center site users list. This list is created in Site Administration.

From Project Customization, you add users to a project and assign them to user groups. Each user group has access to certain Quality Center tasks.

In this exercise, you will add a new project user to the QualityCenter_Demo project.

To add a new project user:

1 Make sure that you are logged in to Quality Center as a project administrator.

For more information on how to open the Project Customization window, see “Starting Project Customization” on page 164.
Lesson 10 • Customizing Projects

2 Open the Project Users page.

In the Project Customization window, click the **Project Users** link. The Project Users page opens and displays a list of users that have been assigned to the project.

3 Add a new user name.

Click the **Add User** button. The Add User to Project dialog box opens.

This dialog box enables you to add an existing user from the list of site users by typing the user's name or by selecting the user from the list of site users. You can also create a new user and add the new user to the project.
Lesson 10 • Customizing Projects

To add an existing user, make sure that **Add user by user name** is selected. In the **Add user by user name** box, type **tom_qc** and click **OK**.

The new user is added to the Project Users list and the user properties are displayed in the Personal Settings area. User personal settings are defined in Site Administration.

### Assigning a User to a User Group

To enable users to do their job, and to protect a project from unauthorized access, Quality Center enables you to assign each user to a specific user group. Each group has access to certain Quality Center tasks. You can use the predefined user groups with their default permissions or you can customize your own user groups with unique sets of permissions.

In this exercise, you will assign the new user **tom_qc** to the **QATester** user group.
Lesson 10 • Customizing Projects

To assign a user to a user group:

1 **Make sure that the Project Users page is displayed.**

If the Project Users page is not already open, click the **Project Users** link in the Project Customization window.

<table>
<thead>
<tr>
<th>User Name</th>
<th>Full Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>alex_qc</td>
<td>Alex Smith</td>
</tr>
<tr>
<td>alice_qc</td>
<td>Alice Jones</td>
</tr>
<tr>
<td>cliff_qc</td>
<td>Cliff Banks</td>
</tr>
<tr>
<td>jenet_qc</td>
<td>James Johnson</td>
</tr>
<tr>
<td>kelly_qc</td>
<td>Kelly White</td>
</tr>
<tr>
<td>mary_qc</td>
<td>Mary River</td>
</tr>
<tr>
<td>michael_qc</td>
<td>Michael Brown</td>
</tr>
<tr>
<td>paul_qc</td>
<td>Paul Writer</td>
</tr>
<tr>
<td>stephen_qc</td>
<td>Stephen Adams</td>
</tr>
<tr>
<td>robert_qc</td>
<td>Robert Phillips</td>
</tr>
<tr>
<td>shelly_qc</td>
<td>Shelly Lime</td>
</tr>
<tr>
<td>tom_qc</td>
<td>Tom Yeller</td>
</tr>
</tbody>
</table>

2 **Select tom_qc from the Project Users list.**

In the **Project Users** list, select **tom_qc**. The user properties are displayed. By default, a new user is assigned to the **Viewer** user group.

3 **Assign tom_qc to the QATester group.**

Under **Not Member Of**, select **QATester** and click the left arrow button to move it to **Member Of**.
4 Remove tom_qc from the Viewer group.

Under Member Of, select Viewer and click the right arrow button to move it to Not Member Of.

Click Save to save the changes to the Project Users page. Click OK.

**Defining a User-Defined Field**

You can define user-defined fields that are unique to your project or modify the behavior of Quality Center system fields.

The fields are stored in Quality Center project entities. For example, the Defect entity contains data entered in the Defects module.

In the following exercise, you will add the Database user-defined field to the Defect entity. This field indicates the server database in use when testing an application.

**To add a user-defined field:**

1 Make sure that the Project Customization window is displayed.

For more information on how to open the Project Customization window, see “Starting Project Customization” on page 164.
Lesson 10 • Customizing Projects

2 Open the Project Entities page.
In the Project Customization window, click the **Project Entities** link. The Project Entities page opens.

![Project Entities](image-url)
3 Add a new user-defined field to the Defect entity.

Under Project Entities, expand Defect.

Click the User Fields folder and click the New Field button. A new field is added under the User Fields folder.

BG_USER_XX indicates a user-defined field under the Defect entity.

4 Rename the default field name.

In the Field Label box, instead of the default name, type Database.

Click Save.

Click OK.
Creating a Project List

You can associate fields with system and user-defined lists. A list contains values that the user can enter in a field.

In the previous exercise you added the Database field. In the following exercise you will create a list and assign it to the Database field. You will then open the New Defect dialog box to view the new field.

To create a project list:

1. Make sure that the Project Customization window is displayed.

For more information on how to open the Project Customization window, see “Starting Project Customization” on page 164.

2. Open the Project Lists page.

In the Project Customization window, click the Project Lists link. The Project Lists page opens.

3. Create a new list.

Click New List. The New List dialog box opens.

In the List Name box, type DB. Click OK to close the New List dialog box.
4 Add Items to your list.

Click **New Item**. The New Item dialog box opens. Type **Oracle** and click **OK**. Repeat the same procedure and add **MS SQL** to the DB list.

Click **Save** to save the changes to the Project Lists page. Click **OK**.

5 Assign the list to the Database field.

In the Project Customization window, click the **Project Entities** link. The Project Entities page opens.

Under **Project Entities**, expand **Defect**.

Expand the **User Fields** folder and select **Database**.
Lesson 10 • Customizing Projects

Under **Field Settings**, in the **Field Type** list, select **Lookup List** to set the field type as a drop-down list. The **Lookup List** section is displayed under the Field Settings section.

Under **Lookup List**, select the **DB** list.

Click **Save** to save the changes to the Project Entities page. Click **OK**.
6 View the new user-defined field in the New Defect dialog box.

Click the **Return** button located on the upper-right corner of the window to exit the Project Customization window and return to your Quality Center project.

In the Defects module, click the **New Defect** button. The New Defect dialog box opens.

![New Defect dialog box](new_defect_dialog_box.png)

The **Database** field is displayed in the New Defect dialog box. Click the down arrow and view the database types you defined. Click **Close**.
Conclusion

Quality Center helps you organize and manage all phases of the application life cycle management process, including defining releases, specifying requirements, planning tests, executing tests, and tracking defects. Throughout each phase, you can analyze data by generating detailed reports and graphs.
### Specify Releases

Specify your release plan and define cycles for your releases.

**To specify your release plan:**
1. Decide how to break up your application releases.
2. For each release, determine how to break it down into cycles.
3. Analyze the progress and quality of your releases and cycles.

### Specify Requirements

Analyze your application and determine your requirements.

**To specify your requirements:**
1. Examine the application under development to determine your scope, goals, objectives, and strategies.
2. Build a requirements tree to define your overall requirements. After you have created tests, you can use them to cover your requirements. In this way, you can keep track of your needs at all stages of the application life cycle management process.
3. For each requirement group in the requirements tree, create a list of detailed requirements. Describe each requirement, assign it a priority level, assign it to releases and cycles, and add attachments if necessary.
4. Generate reports and graphs to assist you in analyzing your requirements. Review your requirements to ensure they meet your scope.
5. Create a baseline of requirements. A baseline can be used as an agreement that all stakeholders are responsible for signing off. This baseline then serves as a point of reference against which changes can be compared. The requirements baseline can be reviewed throughout the project to ensure its ongoing validity.
Plan Tests

Create a test plan, based on your requirements.

**To create a test plan:**
1. Examine your application, system environment, and testing resources to determine your testing goals.
2. Divide your application into modules or functions to be tested. Build a test plan tree to hierarchically divide your application into testing units, or subjects.
3. Determine the types of tests you need for each module. Add a basic definition of each test to the test plan tree.
4. Link each test to requirements.
5. Develop manual tests by adding steps to the tests in your test plan tree. Test steps describe the test operations and the expected outcome of each test. Decide which tests to automate. Afterwards, you can link tests to defects.
6. Create test scripts for tests that you want to automate. You can automate tests using HP testing tools, custom testing tools, or third-party testing tools.
7. Generate reports and graphs to assist in analyzing test planning data. Review your tests to determine their suitability to your testing goals.
8. Create a baseline of tests. A baseline provides you with a snapshot of your test plan at a specific point in time. You can use a baseline to mark any significant milestone in the application life cycle. The baseline then serves as a point of reference against which changes can be compared.

<table>
<thead>
<tr>
<th>Phase</th>
<th>Description</th>
</tr>
</thead>
</table>
| Plan Tests | Create a test plan, based on your requirements.  
**To create a test plan:**
1. Examine your application, system environment, and testing resources to determine your testing goals.
2. Divide your application into modules or functions to be tested. Build a test plan tree to hierarchically divide your application into testing units, or subjects.
3. Determine the types of tests you need for each module. Add a basic definition of each test to the test plan tree.
4. Link each test to requirements.
5. Develop manual tests by adding steps to the tests in your test plan tree. Test steps describe the test operations and the expected outcome of each test. Decide which tests to automate. Afterwards, you can link tests to defects.
6. Create test scripts for tests that you want to automate. You can automate tests using HP testing tools, custom testing tools, or third-party testing tools.
7. Generate reports and graphs to assist in analyzing test planning data. Review your tests to determine their suitability to your testing goals.
8. Create a baseline of tests. A baseline provides you with a snapshot of your test plan at a specific point in time. You can use a baseline to mark any significant milestone in the application life cycle. The baseline then serves as a point of reference against which changes can be compared. |
Lesson 11 • Conclusion

<table>
<thead>
<tr>
<th>Phase</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Execute Tests** | Create test sets and perform test runs.  
*To create test sets and run tests:*
1. Define test set folders and test sets to meet the various testing goals in your project. Assign each test set folder to a cycle. Decide which test sets to include in each test set folder, and which tests to include in each test set.
2. Schedule test runs and assign tasks to application testers.
3. Run the tests in your test sets automatically or manually.
4. View the results of your test runs to determine whether a defect was detected in your application. Generate reports and graphs to help analyze these results. |
| **Track Defects**  | Submit defects detected in your application and track the progress of defect fixes.  
*To submit and track defects:*
1. Submit new defects detected in your application.
2. Link defects to other entities such as requirements, tests, and other defects.
3. Review new defects and determine which ones should be fixed.
4. Correct the defects that you decide to fix.
5. Test a new build of your application. Repeat this process until defects are fixed.
6. Generate reports and graphs to assist in analyzing the progress of defect fixes and to help determine when to release the application. |